Any help is appreciated!!!

How to use TestDisk to recover lost partition
Post Reply
Message
Author
binakajs
Posts: 1
Joined: 11 Sep 2015, 07:54

Any help is appreciated!!!

#1 Post by binakajs » 11 Sep 2015, 08:42

Hello there,

I am having a problem with my "converted" external hard drive. After upgrading my harddrive to solid state hard drive. I started needing the space in the computer to run the programs. Then I converted my old hard drive and made it external (with one of those small portable cases). I used that for all my documents. But recently I decided to get a dock for it. After doing so I lost one of the partitions. The hard drive had two partitions the "recovery" and the "F" (where I had everything stored). Now every time I try to open "F" it says the the drive must be formatted before use.
So now I am trying to recover it with TestDisk. Here is a snapshot of how windows sees it.
Untitled.jpg
Untitled.jpg (168 KiB) Viewed 231 times
Eventhough "F" is broken, I can still access the recovery partition.
By the way, I had windows 7 installed in the hard drive. And now I have windows 10 on my computer.
Things I have tried;
I tried different usb ports of my computer.
I tried the dock connection and the hard drive enclosure.
With TestDisk, I ran the analysis. But I am running it again and this is what its showing so far.
111.jpg
111.jpg (45.63 KiB) Viewed 231 times
and on the TestDrive.log this is the information displayed.

TestDisk 7.0, Data Recovery Utility, April 2015
Christophe GRENIER <grenier@cgsecurity.org>
http://www.cgsecurity.org
OS: Windows 8 (9200)
Compiler: GCC 4.8, Cygwin 1007.34
Compilation date: 2015-04-18T13:01:55
ext2fs lib: 1.42.8, ntfs lib: 10:0:0, reiserfs lib: 0.3.1-rc8, ewf lib: 20120504, curses lib: ncurses 5.9
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sda)=120034123776
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sdb)=750156374016
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive0)=120034123776
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive1)=750156374016
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\C:)=119926685696
filewin32_getfilesize(\\.\D:) GetFileSize err Incorrect function.

filewin32_setfilepointer(\\.\D:) SetFilePointer err Incorrect function.

Warning: can't get size for \\.\D:
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\E:)=34359738368
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\F:)=715792580608
Hard disk list
Disk /dev/sda - 120 GB / 111 GiB - CHS 14593 255 63, sector size=512
Disk /dev/sdb - 750 GB / 698 GiB - CHS 91201 255 63, sector size=512
Drive C: - 119 GB / 111 GiB - CHS 14580 255 63, sector size=512
Drive E: - 34 GB / 32 GiB - CHS 4177 255 63, sector size=512
Drive F: - 715 GB / 666 GiB - CHS 87023 255 63, sector size=512

Partition table type default to None
Drive F: - 715 GB / 666 GiB
Partition table type: Intel

Analyse Drive F: - 715 GB / 666 GiB - CHS 87023 255 63
Current partition structure:

Partition sector doesn't have the endmark 0xAA55
------------------------------------------------------------------------------------------------------------
I will Update when TestDrive its done.
If someone knows that this is a dead end for me trying to recover the partition please let me know. Than I will run photorec and save as much data I can. I cant describe how important this data its to me.
Any help or hints are really appreciated!
THANKS!

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest