Photorec fails to recover file... but succeeds

Using PhotoRec to recover lost data
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 2
Joined: 11 Sep 2015, 19:18

Photorec fails to recover file... but succeeds

#1 Post by damarrin »


First of all: separate accounts on the main page and the forum. Ouch... I don't suppose I'll need the one I created on the site.

Second: thank you for your excellent software. It works very well.

Third: I had an interesting experience with Photorec today.

I have a 2GB pendrive formatted with FAT32 where I keep some .ods files. I create a file at the start of every year and update it daily, saving multiple times per day. It just so happened that this time I forgot to unmount the pendrive before removing it and later I found out that the file I'd been working on didn't write completely to the drive and wouldn't open any more. LibreOffice would complain that the file was damaged and offer to repair it, but would open an empty spreadsheet.

I decided to use Photorec to try and recover the file. It found more than 2000 .ods files, each of them containing a version of the file I was trying to recover, but curiously none of them were newer than April this year. This basically meant that my recovery attempt was unsuccessful. I was really stumped why April was the cut-off date, wondering whether a LibreOffice update changed the way files were written (unlikely) or maybe a system update did a similar thing (more likely, but still unlikely).

I ran Photorec again, but this time I turned on the option to keep corrupt files. It restored the same files... plus a 1.4 GB large .ods. At the start of the file was the half-saved spreadsheet I was trying to rescue, but after that were more files... ones Photorec didn't find.

In the end, I read up a bit about the binary structure of zip files and started manually extracting one .ods after another from the huge binary file. These were all versions of the file I'd been looking for. Before I started looking for a way to automate the process (there were hundreds of files there, too), on a hunch I searched for the last zip file in there, extracted that and voilà! that was the last version of the file before the interrupted save.

So, a complete success, preceded by a few worrying minutes that somehow, for whatever reason, the most recent copies of the file were mysteriously gone.

But now I'm wondering whether perhaps it's some sort of bug in Photorec? It seems that when it got to the half-written file it no longer saw all the other zip files after it and treated the whole thing as one big chunk of data. Just a thought.

Anyway, once again thank you for your excellent software. :-)

User avatar
Site Admin
Posts: 5432
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: Photorec fails to recover file... but succeeds

#2 Post by cgrenier »

Can you run TestDisk, select the 2 GB key, Advanced, Image Creation. Zip the image.dd file and share this file with Google Drive ? This way I will be able to investigate the problem.

Posts: 2
Joined: 11 Sep 2015, 19:18

Re: Photorec fails to recover file... but succeeds

#3 Post by damarrin »

It's all somewhat sensitive information, I'm not sure my work colleagues would approve of me just sending it off somewhere :-)

How about I send you the start of the 1.4 GB file, from the corrupted .ods to the start of the next .ods and we'll see if this helps any?