RAID6 partition Lost

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 4
Joined: 28 Sep 2015, 09:01

RAID6 partition Lost

#1 Post by Franck67 »


after a RAID6 reconstruction, my system can't see my partition anymore, tho its finding some stuffs with testdisk
I have 12 disks, on a 20Tb array.
I ran testdisk with partition type "INTEL", and after a deeper search : i could see my LVM partition with this message :

Code: Select all

Disk /dev/sda - 19 TB / 18 TiB - CHS 2431514 255 63
The harddisk (19 TB / 18 TiB) seems too small! (< 37 TB / 34 TiB)
Check the harddisk size: HD jumpers settings, BIOS detection...

The following partition can't be recovered:
Partition    Start               End                 Size in sectors
> Linux LVM     2138794 202 33  4570309 103 34   39062282240

[ Continue ]
LVM2, 19 TB / 18 Tib

if i seach the partition with type none,
i find a

Code: Select all

>   P Linux LVM2    0 0 1      2431514 156 2   39062282240
it comes in a middle of many (~30) crappy partitions, that i never heard about.. (NTFS/HFS/Linux swap 3 /FAT12/XFS4

but the only option left i have is to quit, cause i cant write when i selected "none".
someone has an idea ?

thx a lot

User avatar
Site Admin
Posts: 5422
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: RAID6 partition Lost

#2 Post by cgrenier »

Are you certain the device was partioned ?

Posts: 4
Joined: 28 Sep 2015, 09:01

Re: RAID6 partition Lost

#3 Post by Franck67 »

no im not.
its part of a NAS server. it came like this when i bought it
the system (open E) is on a flash drive. i was dealing with my shares from that system only.
i never did or touch a partition myself.
but according to the open E support there should be a LVM linux partition
im also french, we could skype or i couldvopen u a ssh access if u want to try yourself