Recover RAID 5 Volume/Partition on OSX

How to use TestDisk to recover lost partition
Post Reply
Message
Author
hipusmc
Posts: 2
Joined: 04 Oct 2015, 15:27

Recover RAID 5 Volume/Partition on OSX

#1 Post by hipusmc » 04 Oct 2015, 15:48

Hi,
I’m in urgent need of you guys assistance regarding an issue with my Raid won’t mount to my OS X Server. Not sure if this will help you guys but i will try to explain and give you as much info as possible. What happened was after i installed Stellar Partition Manger i went Disk Utility to create a boot disk for the OS X Server’s 500GB SSD and restarted. After restart I am able to Raid Volume under Disk utility Only and and SoftRaid but i can’t mount it.

What OS X Server consist of
Mac Mini 6,2
500 GB SSD (Use as boot and Plex Data storage only)
3TB Western Digital External HDD.
3 Partition
(1.4TB) - Use for OS X TimeMachine Backup
(.6TB) - Use for Windows Acorns Backup
(1TB) - Misc

SoftRaid
4 (4TB) Western Digital Red HDD
Setup as RAID 5.

One of these Picture will show that it is (UNKNOWN FORMAT)— <—maybe this is why i can see it but can’t mount it…
I contacted the the Softraid vendor for support and also purchased Diskwarrior 5 from their recommendation and unfortunately they are unable to assist.

After that i googled i somehow ended up here.. :)

I'm pretty sure it had something to do with "Stellar Partition Manger" because up to this point it was working great! So i would conclude its a Damaged/Corrupted OS X partition.. Now the attached pictures FDISK said "GPT PMBR size mismatch (457179135 != 457179647) will be corrected by w(rite)" but Gparted said my partition is fine.

Im currently analyzing 1 out of 4 (4TB) and its taking "FOREVER"....

I apologize if this post is lengthy and if some of the pictures are irrelevant but i really did google and search this forum to the best of my ability but still am unable to get figure it out..

THANKS FOR YOUR ASSISTANCE!!!
Attachments
20151003_222251-Half-size_576x1024.jpg
20151003_222251-Half-size_576x1024.jpg (198.88 KiB) Viewed 436 times
20151003_222155-Half-size_576x1024.jpg
20151003_222155-Half-size_576x1024.jpg (146.5 KiB) Viewed 436 times
2015-10-03 22.29.09-Half-size_576x1024.jpg
2015-10-03 22.29.09-Half-size_576x1024.jpg (82.32 KiB) Viewed 436 times

Sponsored links

hipusmc
Posts: 2
Joined: 04 Oct 2015, 15:27

Re: Recover RAID 5 Volume/Partition on OSX

#2 Post by hipusmc » 04 Oct 2015, 18:29

Sorry here are the other pictures...of my issue with the Raid 5... As soon as the test disk scan is complete ill upload the log file....

Currently using another Macbook Pro Retina to run "Testdisk" only with Raid Enclosure attached....Thanks for your assistance..:)

FWIW. Im using the TestDisk 7.0 version and its taking "Very Long" time to scan... Is that normal? 4tb scanned since 9am CST and its now 12:26pm CST at 1%. Attached is also a remote screenshot that i saw just now logging into my MAC from work... Thanks

Jonny
Attachments
Screen Shot 2015-10-04 at 12.24.34 PM.jpg
Screen Shot 2015-10-04 at 12.24.34 PM.jpg (132.79 KiB) Viewed 435 times
Screen Shot 2015-09-29 at 12.35.36 PM-Half-size_490x594.jpg
Screen Shot 2015-09-29 at 12.35.36 PM-Half-size_490x594.jpg (64.53 KiB) Viewed 435 times
Screen Shot 2015-09-29 at 12.35.20 PM-Half-size_910x688.jpg
Screen Shot 2015-09-29 at 12.35.20 PM-Half-size_910x688.jpg (140.4 KiB) Viewed 435 times

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest