Cant make Partition bootable

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 1
Joined: 07 Oct 2015, 21:43

Cant make Partition bootable

#1 Post by purl »

I have a laptop with the following drive..

Toshiba MQ01ABD075 8455MB (CYL 16383, H16, S63)
750GB (LBA 1,465,149,168 Sectors)

It has been failing to boot recently, and ran testdisk 7.0 to check and fix any errors. Unfortunately, I seem to have made a mistake in this process and the PC will not boot at all 'A required drive partition is missing'. I have tried all recovery options, without success..

testdisk reports Current partition structure:
1 P MS Data 2048 534527 532480 [SONYSYS]
2 P MS Data 534528 3553279 3018752
3 P MS Data 3553280 4085759 532480 [NO NAME]
4 P MS Data 4347904 1406246911 1401899008

Partition 4 contains Windows (8.1). When I select [Analyse]..[Quick Search] Partition 4 is always reported as Deleted. I guess I need to make this Partition bootable .. how do I do this?

The testdisk.log file (attached) contains a number of 'read err: read after end of file'.. what causes this, and can I fix it using testdisk?

Can anyone help?
testdisk.log file
(1.87 KiB) Downloaded 256 times