How to run photorec on NAS with busybox (WD Mycloud) Topic is solved

Using PhotoRec to recover lost data
Locked
Message
Author
miknzau
Posts: 7
Joined: 18 Oct 2015, 11:50

How to run photorec on NAS with busybox (WD Mycloud)

#1 Post by miknzau » 18 Oct 2015, 12:16

Hi,

I have a WD Mycloud Nas that runs busybox which I believe is a very stripped down linux, meaning I cant use apt-get to install photorec.

How do I run photorec? I have downloaded the files on to a USB and mounted that successfully but every time i try to run it i see this...
root@WDMyCloudMirror USB1_c1 # cd testdisk-7.0
root@WDMyCloudMirror testdisk-7.0 # sudo photorec_static
sudo: photorec_static: command not found
root@WDMyCloudMirror testdisk-7.0 # sudo photorec
sudo: photorec: command not found
root@WDMyCloudMirror testdisk-7.0 # photorec_static
-sh: photorec_static: not found
root@WDMyCloudMirror testdisk-7.0 # ls
AUTHORS README icons readme.txt
Android.mk THANKS jni testdisk.8
COPYING VERSION l testdisk_static
ChangeLog documentation.html photorec.8
INFO fidentify.8 photorec_static
NEWS fidentify_static qphotorec.8
So my question is - how to I actually run the photorec application on this device?

Thanks
Last edited by miknzau on 09 Nov 2015, 13:08, edited 1 time in total.

Sponsored links

miknzau
Posts: 7
Joined: 18 Oct 2015, 11:50

Re: How to actually run photorec on NAS with busybox

#2 Post by miknzau » 19 Oct 2015, 09:07

Update: I copied the ARM version of testdisk/photorec onto a USB drive and plugged that into the NAS, navigated to the mount and typed "./photorec"

This worked, the file executes but then it fails trying to load the library libjpeg.so.62

libjpeg.so.62 is not there because BusyBox is so stripped down.

So then I found this site's instruction on compiling a libjpeg on the machine, but alas, the damn thing doesn't have gcc the compiler on board!

So what I really think I need as a copy of the library libjpeg.so.62 complied for ARM that I can drop into the /lib folder on my WD Mycloud Mirror

Can anyone help with that or see any other way around the problem?

P.S. ./testdisk runs fine but the partition is ex4 i believe so i cant use the undelete function of that app

miknzau
Posts: 7
Joined: 18 Oct 2015, 11:50

Re: How to actually run photorec on NAS with busybox

#3 Post by miknzau » 25 Oct 2015, 06:34

Hi any chance someone can help out here?

miknzau
Posts: 7
Joined: 18 Oct 2015, 11:50

Re: How to actually run photorec on NAS with busybox

#4 Post by miknzau » 08 Nov 2015, 12:41

Hi, is anyone able to help me with getting photorec going in this case?

miknzau
Posts: 7
Joined: 18 Oct 2015, 11:50

Re: How to actually run photorec on NAS with busybox

#5 Post by miknzau » 09 Nov 2015, 13:07

I would really like to be able to return this Western Digital NAS to the store I bought it as it has caused me these issues.

Before I can do that - I need to run photorec on it to recover the photos (about 7GB worth) that I copied to it and it's O/S deleted.

As mentioned above, I can run photorec but it stops because the stripped down linux on the NAS (Busybox) does not have the required JPEG library.

A comprehensive google search does not uncover the jpeg laibrary compiled for ARM processors anywhere (except for one dead FTP link) and I can't compile one myself because the unit has no compiler.

So I am pleading with someone (maybe the admin of this form might like to comment) to advise how I might get this Jpeg library onto the unit so photorec will run.

Thank you very much in advance.

miknzau
Posts: 7
Joined: 18 Oct 2015, 11:50

Re: How to run photorec on NAS with busybox (WD Mycloud)

#6 Post by miknzau » 24 Nov 2015, 08:12

Hi,

I would really appreciate it if someone could reply to this thread. I am asking something pretty specific here I know, but surely someone who is very linux savvy can contribute?

Thanks in advance.

User avatar
cgrenier
Site Admin
Posts: 3813
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: How to run photorec on NAS with busybox (WD Mycloud)  Topic is solved

#7 Post by cgrenier » 25 Nov 2015, 14:01

Can you try using the library from http://www.cgsecurity.og/libjpeg_arm-no ... abi.tar.gz ?

Code: Select all

cd /usr/lib
tar xzf libjpeg_arm-none-linux-gnueabi.tar.gz
ldconfig -v
ldconfig should list libjpeg.so.62.
If it's ok, try to run photorec again

miknzau
Posts: 7
Joined: 18 Oct 2015, 11:50

Re: How to run photorec on NAS with busybox (WD Mycloud)

#8 Post by miknzau » 26 Nov 2015, 04:43

cgrenier wrote:Can you try using the library from http://www.cgsecurity.org/libjpeg_arm-n ... abi.tar.gz ?

Code: Select all

cd /usr/lib
tar xzf libjpeg_arm-none-linux-gnueabi.tar.gz
ldconfig -v
ldconfig should list libjpeg.so.62.
If it's ok, try to run photorec again
Note: there was a typo in the URL - correct URL is http://www.cgsecurity.org/libjpeg_arm-n ... abi.tar.gz

!!!!!!!!!!!!!

IT WORKED!

!!!!!!!!!!!!

Photorec is now running!!

Thank you so much for your help cgrenier! :D

Locked

Who is online

Users browsing this forum: No registered users and 3 guests