TestDisk not recovering files?

Using PhotoRec to recover lost data
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Posts: 1
Joined: 27 Oct 2015, 16:55

TestDisk not recovering files?

#1 Post by eppiedot »

I have a corrupted flash drive with lots of documents and photos (I really only care about the photos - most are backed up, but not all of them). I ran Chkdsk on it, and it won't work because it's a RAW drive, and the disk properties show all space used and all space available.

I was directed to photorec, which didn't recover anything, and then to TestDisk, but I am still having trouble locating files. It is showing an unknown partition, and when I make an image of it and compress, it's 375 KB. Please help - I'd like to recover the few files that weren't backed up :)

User avatar
Site Admin
Posts: 5434
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: TestDisk not recovering files?

#2 Post by cgrenier »

When using PhotoRec, choose [Whole] instead of [Free].