Partitions can't be recovered on external HD

How to use TestDisk to recover lost partition
Post Reply
Message
Author
gabicats
Posts: 1
Joined: 17 Nov 2015, 05:55

Partitions can't be recovered on external HD

#1 Post by gabicats » 17 Nov 2015, 06:30

Hi!

So I have a 500 GB external HD that I had 1 or 2 partitions on, I can't really remember. One day when I tried to plug my HD I got an error message that said the device was not readable by my computer. I get this error message every time. After doing some research I figured it was a corrupted partition. I have been running TestDisk 7.0, but not having too much luck as of right now finding a solution. I have been on Google for hours upon hours trying to make sense of everything, and am more worried about moving forward to avoid making matters worse. I am not familiar with TestDisk at all, but here is where I am stuck at the moment:

The harddisk (500 GB / 465 GiB) seems too small! (< 1000 GB / 931 GiB)
Check the harddisk size: HD jumpers settings, BIOS detection...

The following partitions can't be recovered:
Partition Start End Size in sectors
> MS Data 976768064 1953536065 976768002
Mac HFS 976773101 1953546140 976773040

>>>NEXT SCREEN >>>

Disk /dev/rdisk1 - 500 GB / 465 GiB - 976773167 sectors
Partition Start End Size in sectors
>D EFI System 40 409639 409600 [EFI]
D MS Data 63 976768064 976768002
D Mac HFS 65 976773104 976773040
D Mac HFS 409640 492798871 492389232
D Mac HFS 493061016 976510983 483449968


I've read various things telling me to copy and recover single files, change the partition characteristics, try to recover the partition, and/or to go into a deep search from here, but I am not even sure which drive to select, so have not moved forward from here. No idea what I am looking at or what to do, I feel like I am just wasting my time going in circles. PLEASE HELP!

(Not sure if any of the following info is vital, but here it is anyways just in case)
Late 2008 MacBook
Currently running OS X 10.10.5
Processor: 2 GHz Intel Core 2 Duo
Memory: 2 GB 1067 MHz DDR3

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests