No files after MFT Repair

Using TestDisk to repair the filesystem
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Locked
Message
Author
Spegs21
Posts: 1
Joined: 17 Dec 2015, 15:28

No files after MFT Repair

#1 Post by Spegs21 »

I have an external drive in a usb enclosure that windows was asking to format. I booted a live cd and ran testdisk. It recognized the disk as NTFS and found the partition and I was able to view the files. I repaired it as a primary partition and try tried to get Windows to recognize it but it still would not. I fired the live cd back up and looked at the NTFS boot sector. The backup was bad so I repaired it. No problem there. The problem occured when I noticed the MFT were different. I recovered the primary from the backup and now none of the files appear in the partition. I realize I probably should not have done that considering the files were accessible before but I did not think it would have that effect.

I'm running through ZAR X now and will try GetMyDataBack. Is there any hope here or is it hosed?

Sponsored links

User avatar
Fiona
Posts: 2835
Joined: 18 Feb 2012, 17:19
Location: Ludwigsburg/Stuttgart - Germany

Re: No files after MFT Repair

#2 Post by Fiona »

I don't recommend to fix a backup of the boot sector.
It modifies your file system.
Something to try would be to run a RebuildBS and have another try to list your files.
Please let me know, did it work for you?
Don't use RepairMFT either!

Fiona

Locked