MyBook 3T went raw, then unallocated

How to use TestDisk to recover lost partition
Message
Author
dillman
Posts: 11
Joined: 24 May 2012, 02:19

MyBook 3T went raw, then unallocated

#1 Postby dillman » 24 May 2012, 02:26

I finally created a bootable "RescueCD" disc, and ran testdisk from it, and WOW...there are all my files and data..still there..I thought they were lost forever...but...nothing I've been able to do from within Testdisk will restore the disc to normal function...ie windows still doesn't see it, the USB interface keeps resetting after a short time.
I've tried the rebuild BS, and writing the data, etc...I don't know what else to do??

I can copy files off of it, slowly..but the only other drive that is available when booting this way, is very small. I've tried mounting the MyBook 3T, /dev/sdb1, and the seagate goflex 3T, /dev/sdc1, but they wont let me mount either of them... ugh...help...

I analyzed, it shows my partition, I hit enter to continue, it says deeper search or write...I select WRITE as that is the partition I was looking for...it gives Partition: Write error


Peace,
Lynny

Sponsored links

User avatar
remy
Posts: 457
Joined: 25 Mar 2012, 10:21
Location: Strasbourg, France.
Contact:

Re: MyBook 3T went raw, then unallocated

#2 Postby remy » 28 May 2012, 08:15

It could be hardware related (impossible to write partition because sector0 is a bad sector) or it could also be a rights problem : did you launch testdisk as root user, with administrative rights ?

What is the error message when trying to mount your backup drive ?
J'ai pour habitude d'aller au bout de l'aide que j'apporte. Si vous pensez que je vous ai abandonné, et que je ne l'ai pas fait explicitement, c'est que votre message est enfoui avec d'autres. Relancez-moi (modérément) par mail.

dillman
Posts: 11
Joined: 24 May 2012, 02:19

Re: MyBook 3T went raw, then unallocated

#3 Postby dillman » 29 May 2012, 20:42

I'm running testdisk from a linux based rescueCD. I've managed to get the drive to mount, once, and more than once I've been able to see the data on the drive with Testdisk. I still have no success when I try to WRITE, or rebuild the MBR/MFT...

I'm not sure how Testdisk ran, I guess I assumed root, I'll check it out, and let you know.

Thanks for the reply.

Peace,
Lynny

dillman
Posts: 11
Joined: 24 May 2012, 02:19

Re: MyBook 3T went raw, then unallocated

#4 Postby dillman » 30 May 2012, 14:33

Testdisk is running from a root prompt on the rescueCD...



Peace,
Lynny

User avatar
remy
Posts: 457
Joined: 25 Mar 2012, 10:21
Location: Strasbourg, France.
Contact:

Re: MyBook 3T went raw, then unallocated

#5 Postby remy » 30 May 2012, 23:42

So, if you're not able to write, the best way to recover your data could be either to copy from testdisk, or to mount your partition with a loopdevice from linux.
J'ai pour habitude d'aller au bout de l'aide que j'apporte. Si vous pensez que je vous ai abandonné, et que je ne l'ai pas fait explicitement, c'est que votre message est enfoui avec d'autres. Relancez-moi (modérément) par mail.

dillman
Posts: 11
Joined: 24 May 2012, 02:19

Re: MyBook 3T went raw, then unallocated

#6 Postby dillman » 31 May 2012, 06:07

I've tried to copy data from it, using testdisk. Its very slow, and unreliable..as in, it shows you nothing of its progress, success, or failure..
and eventually, it does fail, and gives a big, long stream of failed to copy file blah blah...but it does copy some!?
I have a 1.5 T music collection on there that I really, really want to save..and this is not going well with the testdisk copying..Or was that when I got it to mount, and tried moving files over..hell, I can't remember now, I've tried so many things, different times..
Oh, in testdisk, it eventually "craps out" and when I exit testdisk, and fdisk -l again..the drive now has a new name..ie /dev/sdb1, then next time it will be /dev/sdc1, then /dev/sdd1, etc, etc...every time it fails it gets a new device letter? that help any?
which is similar to what it does in windows...drive light flashes..flashes...windows sees it as an unformatted drive..then the external drive interface resets itself, and the process starts all over again..over and over...?
this drive has been pampered, and well taken care of since I got it. I bought it to copy all that music onto..and I've treated it with kid gloves ever since...I dont understand this, at all.. :(

Please explain the loopdevice mounting process, and I'll give it a go, if it will benefit my situation.

Maybe I'm doing something wrong in the whole testdisk process..? I thought once you ran the simple search, if it found your partition, you just write from there..Once I get the data I need to recover, WD which used to be the trusted brand in my household, stands for We're Done! I've already started migrating toward seagate drives, but I'm having an issue with one of them, in the NAS..its 3T also...I'm just wondering what is the issue...all these 3T's having trouble..or is it the newer windows buggering them all up?? Thanks again for your assistance, its very much appreciated.

Peace,
Lynny

User avatar
remy
Posts: 457
Joined: 25 Mar 2012, 10:21
Location: Strasbourg, France.
Contact:

Re: MyBook 3T went raw, then unallocated

#7 Postby remy » 01 Jun 2012, 00:17

Nothing wrong in your process. These symptoms are disk failure. You should duplicate your disk on another 3TB with tool like ddrescue under gnu/linux (gnu ddrescue) and recover on the copy.

I'm afraid loopdevice won't help there, because your disk will still disconnect and reconnect when too much accessed. With ddrescue, you'll be able to continue copy where it stopped before.
J'ai pour habitude d'aller au bout de l'aide que j'apporte. Si vous pensez que je vous ai abandonné, et que je ne l'ai pas fait explicitement, c'est que votre message est enfoui avec d'autres. Relancez-moi (modérément) par mail.

dillman
Posts: 11
Joined: 24 May 2012, 02:19

Re: MyBook 3T went raw, then unallocated

#8 Postby dillman » 01 Jun 2012, 04:38

Interesting, Remy, thank you. I will certainly look into ddrescue. I can't believe that a relatively brand new drive would fail like that..really shakes my faith in WD..again...I hope they will cover the drive under warranty..even though I removed it from the enclosure...the drive itself should still be covered. I hope..

Now, I just need another 3T to back up onto.. :(


Peace,
Lynny

User avatar
remy
Posts: 457
Joined: 25 Mar 2012, 10:21
Location: Strasbourg, France.
Contact:

Re: MyBook 3T went raw, then unallocated

#9 Postby remy » 01 Jun 2012, 08:01

You have to let the disk in the enclosure. Not for warranty purpose, but because of hardware encryption made by enclosure PCB.
J'ai pour habitude d'aller au bout de l'aide que j'apporte. Si vous pensez que je vous ai abandonné, et que je ne l'ai pas fait explicitement, c'est que votre message est enfoui avec d'autres. Relancez-moi (modérément) par mail.

dillman
Posts: 11
Joined: 24 May 2012, 02:19

Re: MyBook 3T went raw, then unallocated

#10 Postby dillman » 01 Jun 2012, 15:04

Yeah, don't get me started on that encryption BS..I have the encryption/IO interface on the drive, its just not in its original enclosure.

ddrescue is doing its thing...but...I need a script..a batch file..something to automate this process...

I start it with

ddrescue -v /dev/sdd1 /mnt/backup/rescue.img /mnt/backup/rescue.log

and it goes for a little while then dies..input file disappeared..I have to then

fdisk -l

over and over until it reappears...then start it over again....there has to be a way to script this..????
I've been messing with it all morning...and its only about 3 gigabytes in...sigh..I can't sit with it all day..lol..

Peace,
Lynny


Return to “Partition Recovery”

Who is online

Users browsing this forum: Bing [Bot] and 0 guests