Image creation bug

How to use TestDisk to recover lost partition
Post Reply
Message
Author
szg0000
Posts: 4
Joined: 18 Jan 2016, 21:41

Image creation bug

#1 Post by szg0000 » 18 Jan 2016, 21:54

After entering into "Image creation" tool, you can choose the destination directory of the image.
Here:
2016-01-18 (1).png
2016-01-18 (1).png (44.21 KiB) Viewed 937 times
After the image creation stops, the image will be saved. Everything is fine, if the destination directory is the current "testdisk-7.1-WIP".


If the destination directory is changed to an another, e.g. up one folder, error message comes up, after image creation ends.

This:
2016-01-18.png
2016-01-18.png (11.14 KiB) Viewed 937 times
But there is enough space on drive.

Sponsored links

User avatar
Fiona
Posts: 2836
Joined: 18 Feb 2012, 17:19
Location: Ludwigsburg/Stuttgart - Germany

Re: Image creation bug

#2 Post by Fiona » 20 Jan 2016, 08:07

Standard path as the destination is the testdisk folder.
When you'd like to change the directory, you can mark these two dots at the upper area of the display and pressing enter?
Each time you'll get 1 directory up until you see all drives.
There you can choose another drive and when you'd like to copy your image to another folder, you can select a folder and enter it using the right arrow key on your keyboard and starting the copying process.
Did you already try it ?

Fiona

User avatar
cgrenier
Site Admin
Posts: 3693
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Image creation bug

#3 Post by cgrenier » 20 Jan 2016, 08:29

Please download the latest 7.1-WIP, try again with your antivirus disabled and post the testdisk.log file content if the problem remain.

szg0000
Posts: 4
Joined: 18 Jan 2016, 21:41

Re: Image creation bug

#4 Post by szg0000 » 20 Jan 2016, 10:19

The problem remains.

I was not able to upload TXT file, because "The extension log is not allowed." error message comes up when I tried.
I attached in JPG file, with some error message translation, because my windows is speaking hungarian. I am using windows 10, 64bit, this is not in the log file.
testdisklog__.jpg
testdisklog__.jpg (243.13 KiB) Viewed 906 times

User avatar
cgrenier
Site Admin
Posts: 3693
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Image creation bug

#5 Post by cgrenier » 20 Jan 2016, 14:48

It's not the latest 7.1-WIP (WIP=Work In Progress), it has been updated today. There should be an error message in the log just before the "no space left" message

szg0000
Posts: 4
Joined: 18 Jan 2016, 21:41

Re: Image creation bug

#6 Post by szg0000 » 20 Jan 2016, 15:15

Yes, you are right. That build was not the latest.
There is no build date next to "latest 7.1-WIP" download icon on the homepage.

So, I downloaded the latest, as you mentioned. The logfile has differecies.
The diff. is:
**************************************************************************************
disk_image pwrite() failed: Illegal seek
disk_image pwrite() failed: Illegal seek
disk_image pwrite() failed: Illegal seek
disk_image pwrite() failed: Illegal seek
disk_image pwrite() failed: Illegal seek
disk_image pwrite() failed: Illegal seek
disk_image pwrite() failed: Illegal seek
disk_image pwrite() failed: Illegal seek
disk_image pwrite() failed: Illegal seek
disk_image pwrite() failed: Illegal seek

**************************************************************************************
This error message in ~7500 lines.

After 7500 line of this message comes:
No space left for the file image.

User avatar
cgrenier
Site Admin
Posts: 3693
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Image creation bug

#7 Post by cgrenier » 23 Jan 2016, 11:04

I have uploaded a new 7.1-WIP with a workaround. Can you test if the problem is solved ?
If it's not the case, please tell me what the log file contains this time.

szg0000
Posts: 4
Joined: 18 Jan 2016, 21:41

Re: Image creation bug

#8 Post by szg0000 » 23 Jan 2016, 12:11

Bug solved. Tried in 2 different folders, and the image is really placed.
Image created successfully.

Still some error messages in the logfile,
filewin32_getfilesize(\\.\D:) GetFileSize err Nem megfelelő funkció.
filewin32_setfilepointer(\\.\D:) SetFilePointer err Nem megfelelő funkció.
Warning: can't get size for \\.\D:
filewin32_getfilesize(\\.\E:) GetFileSize err Nem megfelelő funkció.
filewin32_setfilepointer(\\.\E:) SetFilePointer err Nem megfelelő funkció.
Warning: can't get size for \\.\E:


But no problem with "Image creation" function.
My proposal is an additional information in the logfile, to see where is the image placed: Image created succesfully: [PATH]/image.dd

Bug solved.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests