Trying to recover 3TB RAID-1 volume

How to use TestDisk to recover lost partition
Post Reply
Message
Author
gerryan
Posts: 2
Joined: 30 Jan 2016, 08:48

Trying to recover 3TB RAID-1 volume

#1 Post by gerryan » 30 Jan 2016, 09:32

Hi,

I am seeking help to recover the data from a 3TB RAID-1 array which 'disappeared' when I installed an upgrade of the RAID software (driver + utility).

The computer is an HP MicroServer with an integrated AMD RAID controller with one pair of 2TB drives in RAID 1 with 2 logical volumes, and a pair of 3TB drives in RAID 1 with a single logical volume occupying the entire disk. After upgrading the RAID software, the 3TB array had simply disappeared and the utility showed the two 3TB drives as 'available' but not in any array.

I recreated the RAID-1 array (specifying 'NO initialisation' so that data would not be overwritten) and restarted the computer - after restart, the missing drive showed up in Windows Disk Management as 'not initialised'. I then 'initialised' the disk but Windows then reported that the drive need to be formatted before it could be accessed.

At this point, I downloaded TestDisk and ran it -- I selected the disk, selected 'EFI GPT' as the partition table type
and then ran Analyse .... Quick Search which gave the following warning:
Warning: number of bytes per sector mismatches 1024 (NTFS) != 512 (HD)
but then continued and reported that it had found a partition which I was able to browse (list files) and which appeared to be intact.

I then pressed Enter to continue, selected Write + confirm ..... Quit and restarted as instructed. (log file attached)

After the restart, the volume was now assigned a drive letter but Windows still says it needs to be formatted, so it appears that the partition table is not being recognized by Windows.

is there any way I can repair this volume so that Windows will be able to recognize it?

OR - what is the best way to recover the data (>2Gb) to other media/device?

Thanks (in hope and anticipation),

Gerry
Attachments
testdisk_1.zip
(25.12 KiB) Downloaded 24 times

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3562
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Trying to recover 3TB RAID-1 volume

#2 Post by cgrenier » 01 Feb 2016, 13:54

Run TestDisk, Advanced, Boot, RebuildBS, List.
If you can see your files, choose Write, confirm, Quit, restart your computer.

If Windows has still problem to access it, run "cmd" (right click run as administrator), "chkdsk /f d:" (replace d: by the correct drive letter)

gerryan
Posts: 2
Joined: 30 Jan 2016, 08:48

Re: Trying to recover 3TB RAID-1 volume

#3 Post by gerryan » 02 Feb 2016, 04:15

Thank you very much - that fixed it!

Regards,

Gerry

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest