Recovering QNAP 451 Drive incorrectly mounted back

How to use TestDisk to recover lost partition
Post Reply
Message
Author
ylsf
Posts: 1
Joined: 04 Feb 2016, 15:25

Recovering QNAP 451 Drive incorrectly mounted back

#1 Post by ylsf » 04 Feb 2016, 15:41

Hello all,

I have a WD Red NAS 4 TB drive that was connected to my QNAP 451 as a second drive (mounted originally as a single drive, not part of a raid system). I wanted to copy data off of it quickly to another computer so I removed the physical drive and connected it to a Windows PC via a SATA docking station not even thinking about the formating and difference between Linux file systems and Windows. I realized the mistake when I couldn't read the drive on the PC (without extra utilities) so I remounted it on the QNAP right away. It didn't show back up on the system and prompted me to "Restore the RAID" system. I was thinking that maybe QNAP called it a RAID even thought it wasn't really a RAID so I clicked "Restore" (yeah, I series of stupid mistakes). It then showed the drive as empty. I dismounted the drive (first time I didn't dismount it, I thought it was a hot swapable system) and removed it.

I have run some other software trying to read the linux partitions on the Windows 7 machine and even tried various recovery software. One program was working to recover the files (including folders and file names) but the files themselves were all mixed up (corrupt data.. like playing an audio file played back a portion of a movie that I had saved on the drive, etc).

I learned about Testdisk recently so I want to give it a try. I looked first through the menus to see if I could find any files already on the system. There is one section of the drive (partition) that does show some QNAP file system files. I am guessing this was put on there from me trying to restore the RAID. The other partitions don't give me an option to list any files.

I am doing a deep analysis right now. I have attached a backup log and also a copy of the screen cap of test disk running. Looks like it will take a few days to finish
Attachments
Screencap_testdisk.png
ScreenCap _ test disk runnig
Screencap_testdisk.png (31.09 KiB) Viewed 244 times

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest