RAW usb flash drive no partitions listed after analyze

How to use TestDisk to recover lost partition
Post Reply
Message
Author
rickymartino
Posts: 1
Joined: 14 Apr 2016, 06:43

RAW usb flash drive no partitions listed after analyze

#1 Post by rickymartino » 14 Apr 2016, 06:49

Hi guys, my friend has given me his USB with important work on it and asked me to fix it because I'm usually good with computers but I have never had an issue like this.

What ive worked out is that some how his usb format has been converted to RAW.
After doing alot of research I tried to use testdisk to analyze the drive, but no partitions come up.
Im believe the boot sector may be corrupted or the partition table, but I have no idea.

Before the scan this is what came up:
Image

And here is the log file:

Code: Select all

Thu Apr 14 15:37:49 2016
Command line: TestDisk

TestDisk 7.0, Data Recovery Utility, April 2015
Christophe GRENIER <grenier@cgsecurity.org>
http://www.cgsecurity.org
OS: Windows 8 (9200)
Compiler: GCC 4.8, Cygwin 1007.34
Compilation date: 2015-04-18T13:01:55
ext2fs lib: 1.42.8, ntfs lib: 10:0:0, reiserfs lib: 0.3.1-rc8, ewf lib: 20120504, curses lib: ncurses 5.9
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sda)=2000398934016
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sdb)=120034123776
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sdc)=2000365289472
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sdd)=15917383680
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive0)=2000398934016
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive1)=120034123776
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive2)=2000365289472
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive3)=15917383680
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\C:)=119439097856
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\D:)=2000396746752
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\E:)=15917383680
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\F:)=2000364240896
Hard disk list
Disk /dev/sda - 2000 GB / 1863 GiB - CHS 243201 255 63, sector size=512
Disk /dev/sdb - 120 GB / 111 GiB - CHS 14593 255 63, sector size=512
Disk /dev/sdc - 2000 GB / 1862 GiB - CHS 243197 255 63, sector size=512
Disk /dev/sdd - 15 GB / 14 GiB - CHS 1935 255 63, sector size=512
Drive C: - 119 GB / 111 GiB - CHS 14520 255 63, sector size=512
Drive D: - 2000 GB / 1863 GiB - CHS 243201 255 63, sector size=512
Drive F: - 2000 GB / 1862 GiB - CHS 243197 255 63, sector size=512

Partition table type default to Intel
Disk /dev/sdd - 15 GB / 14 GiB
Partition table type: Intel

Analyse Disk /dev/sdd - 15 GB / 14 GiB - CHS 1935 255 63
Current partition structure:

Partition sector doesn't have the endmark 0xAA55

search_part()
Disk /dev/sdd - 15 GB / 14 GiB - CHS 1935 255 63
file_pread(7,13,buffer,31088642(1935/45/33)) lseek err Invalid argument
file_pread(7,1,buffer,31088642(1935/45/33)) lseek err Invalid argument
file_pread(7,8,buffer,31088647(1935/45/38)) lseek err Invalid argument
file_pread(7,3,buffer,31088655(1935/45/46)) lseek err Invalid argument
file_pread(7,3,buffer,31088702(1935/46/30)) lseek err Invalid argument
file_pread(7,8,buffer,31088718(1935/46/46)) lseek err Invalid argument
file_pread(7,11,buffer,31088765(1935/47/30)) lseek err Invalid argument
file_pread(7,2,buffer,31090687(1935/77/62)) lseek err Invalid argument
file_pread(7,13,buffer,31088643(1935/45/34)) lseek err Invalid argument
file_pread(7,1,buffer,31088658(1935/45/49)) lseek err Invalid argument
file_pread(7,1,buffer,31088705(1935/46/33)) lseek err Invalid argument
file_pread(7,1,buffer,31088726(1935/46/54)) lseek err Invalid argument
file_pread(7,1,buffer,31088776(1935/47/41)) lseek err Invalid argument
file_pread(7,1,buffer,31090689(1935/78/1)) lseek err Invalid argument

Results

interface_write()
 
No partition found or selected for recovery
simulate write!

write_mbr_i386: starting...
Store new MBR code
write_all_log_i386: starting...
No extended partition
SIGHUP detected! TestDisk has been killed.
How do I go about repairing this USB?
Any help is greatly appreciated thank you.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3458
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: RAW usb flash drive no partitions listed after analyze

#2 Post by cgrenier » 14 Apr 2016, 18:38

Using TestDisk 7.1-WIP, please post the results after Analyse, Quick Search and Deeper Search

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests