Recovery: "You need to format the disk in Drive E: " Topic is solved

Using TestDisk to repair the filesystem
Locked
Message
Author
jimichrome
Posts: 1
Joined: 13 Apr 2016, 19:56

Recovery: "You need to format the disk in Drive E: "  Topic is solved

#1 Post by jimichrome » 14 Apr 2016, 23:31

This has a happy ending, my amateur story might help others if they run into and need to solve a similar problem. I need to credit TestDisk with getting me out of this pickle, but I have a question about the screen shot below.

I have a old 250GB Western Digital WD2500 Caviar SE Drive and could no longer access 58GB of Folders and files. Attempting access, Windows10 gave msg: “You need to format the disk in Drive E: before you can use it. Do You want to format it?” (don't format!!) I made a RAW copy of my defective drive for backup, didn't need it, but it made me feel more confident when I felt like I didn't know what I was doing.

The fault was caused by a $8 IDE to USB converter that developed intermittant solder connections that had the same effect as prematurely disconnecting a USB connection while drive was R/W active, hence the seemingly permanent prompt (to format drive) error msg.

Google directed me to a Youtube tutorial(s) for recovering Drive data: I opened a command prompt in admin mode and ran “chkdsk”: C:\windows\system32>chkdsk (drive letter): /f (and) /r
Both tests immediately aborted, but stay posted, later on they raised the dead.

The youtube tutorial had me run “Find and Mount” a free s/w app. It found my defective drive and reported it had 1 (one) partition.

photorec_win.exe In running this program I was relieved to see lost photos and files being found and saved, that's the good news, not so good was saved files had new names and were not in original folders. A better recovery is ahead.

testdisk_win.exe This is where I have a question to satisfy my curiosity.
Being a newbie, I felt Testdisk somewhat intimidating especially the “Partition Table Type”page:
Testdisk1.jpg
Testdisk1.jpg (156.9 KiB) Viewed 750 times
I was under the assumption from “Find & Mount” my bad WD2500 drive had “ONE” partition, but TestDisk program default selected “none”. Then TestDisk warned me: “Do not select NONE” if you have “ONE”. (confused !!) Selecting INTEL was no help. I proceeded with default “NONE”. (as long as I'm not writing on the disk I suppose). In the end it turned out to not matter.

Proceeding forward the next page defaulted to “BOOT”, the page after that enabled me to “REBUILD THE BOOT SECTOR” which I did. ( can't recall what if any error conditions were reported during this process) . (In retrospect I think this action was a major step in recovery, but I did not notice or realize it at the time).

I busied myself for some time with Photorec file recovering and noticed a changed error message on further access attempts of the bad Disk Drive; error msg changed from: “You need to format the disk in Drive E: before you can use it.” to a different message: “The file or directory is corrupted and unreadable”.
Again, I ran C:\windows\system32>chkdsk (drive letter): /f this time and in no time a long string a sector misalignment corrections+ etc. took place in the open chkdsk window. Before I could read “Windows found and corrected all kinds of misaligned stuff, my formerly faulty Disk drive name appeared along with ALL files and folders.... 100% recovered. !! Thank you very much!

Sponsored links

Locked

Who is online

Users browsing this forum: No registered users and 2 guests