Restore partition table of 3 HDD Linux RAID5

How to use TestDisk to recover lost partition
Post Reply
Message
Author
marcomes
Posts: 1
Joined: 18 May 2016, 12:56

Restore partition table of 3 HDD Linux RAID5

#1 Post by marcomes » 18 May 2016, 13:17

Hi, I really hope that someone can help me with this problem:

Originally, I created a 3 HDD Linux RAID5 compound using a Synology DiskStation. Afterwards, I deleted all the existing partitions using the Windows 7 Disk Management tool in order to make a new setup. A few hours later, one of my servers crashed, but on the RAID5 of the NAS was a very important backup, which I urgently need now.

The good thing is, that (in my understanding of disk formatting) I just deleted the partition table. I did not overwrite anything since I deleted the partitioning in Windows.

So I tried to restore the original formatting using TestDisk via the Parted Magic live CD.

Here are screenshots of what I get, when I perform a quick search:
1raid5.JPG
1raid5.JPG (59.79 KiB) Viewed 233 times
1raid5-2.JPG
1raid5-2.JPG (60.44 KiB) Viewed 233 times
1raid5-3.JPG
1raid5-3.JPG (61.58 KiB) Viewed 233 times
It looks quite good, in my opinion.

But Testdisk won't allow me to change the partition status of more than two partitions. I tried almost every configuration, but I always get a "Bad Structure" whenever there are more than two partitions, that are not marked as deleted (D).

How can I restore the original formatting?

Thanks a lot!

Regards, Marco

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3812
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Restore partition table of 3 HDD Linux RAID5

#2 Post by cgrenier » 19 May 2016, 06:34

In Options, set align partitions to No. Try again a search, Are you able this time to set the md0 and md1 partitions as P(rimary) ?
Note that you will need to boot from a Linux LiveCD/LiveUSB (ie. Fedora) to access your data if the NAS failed to mount the partitions.

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests