USB Sandisk Cruzor Edge - no longer SMART - HELP

How to use TestDisk to recover lost partition
Post Reply
Message
Author
backupb42l8
Posts: 1
Joined: 22 Jun 2016, 23:00

USB Sandisk Cruzor Edge - no longer SMART - HELP

#1 Post by backupb42l8 » 22 Jun 2016, 23:18

My USB storage device suddenly stopped working earlier today, I don't recall it being removed unsafely but it can fall out, and I guess I automatically insert it without thinking so think this is what happened today. Had the initial message about not able to read the file, format the disk but also been getting please insert a disk into removable disk (D:) not, although it does switch between both messages.

Tried various recovery software without any success (no format), then under their advice tried to format with no success. I then followed these guidelines http://html5.litten.com/updated-how-to- ... ecame-raw/ but have just realised that USB storage device didn't pass the SMART test.

Currently going through a deeper search with lots of read error messages so I am guessing no files/partitions will be found, and I realise I don't want to progress with re writing the partition table if this is the case.

My question is if this fails and the device hasn't passed the SMART test is there anyway in retrieving my files? I presume they are still there, hence all the read error messages!?

Any advice would be greatly appreciated.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3615
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: USB Sandisk Cruzor Edge - no longer SMART - HELP

#2 Post by cgrenier » 23 Jun 2016, 06:06

Can you remove the disk from the USB case and connect it directly via SATA ?
Boot from a Linux LiveCD/DVD/USB (ie. Fedora) and use ddrescue to clone the disk to a new empty one.
Once it's done, remove the original disk and use PhotoRec on the clone.

As the SMART status has failed, I don't think it's still possible to recover your data via a software method but you can always try.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests