Unable to play recovered mov. files

Using PhotoRec to recover lost data
Post Reply
Message
Author
zebralion
Posts: 1
Joined: 05 Jul 2016, 16:45

Unable to play recovered mov. files

#1 Post by zebralion » 05 Jul 2016, 16:51

Hi, I am desperate for help. I apologize in advance if my english is bad (it's not my first language)

I accidentally deleted everything on my camera memory card (Canon powershot G12). I haven't taken any new pictures or recorded any movies since. I managed to restore most of the pictures, but somehow the .mov files just won't work. The files are called something like f13339328_mdat or f1300000_ftyp with different numbers of course. They either can't be played, or it's a black screen with a scratchy noise. One of them has a frame from the movie. Is there any, any way I can make this work, or are the files just totally corrupted? I am a bit lost in how I should use this software.
Please help this rookie!

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3694
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Unable to play recovered mov. files

#2 Post by cgrenier » 05 Jul 2016, 19:32

Using PhotoRec 7.1-WIP, in theFileOpts menu, enable
[X] mov/mdat Recover mdat atom as a separate file
and restart the data recovery.

List the mov file (sort them by name).
Use two consecutive filenames to concatenate the files together

Code: Select all

cat f123_ftyp.mov f456_mdat.mov > 1.mov
cat f456_mdat.mov f123_ftyp.mov > 2.mov
(Use "cat" under Linux or Mac OS X, "type" if using Windows), check if you can play one of the 2 videos.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests