Partition sector doesn't have the endmark 0xAA55 + Partition Write Errors- Need help

How to use TestDisk to recover lost partition
Post Reply
Message
Author
sunil3k
Posts: 1
Joined: 21 Jul 2016, 08:48

Partition sector doesn't have the endmark 0xAA55 + Partition Write Errors- Need help

#1 Post by sunil3k » 21 Jul 2016, 11:43

Hi,

I am using TestDisk for the first time. I am not a techie but can follow technical instructions.

I have a Lenovo G50 with 1 TB internal HDD. It has Windows 8.1 64 bit installed.
There were 3 drives -
C: drive - which had the Windows installed (drive size ~150 GB)
D: drive - which had my personal files (drive size~400GB)
F: drive - which had my business files (drive size ~400GB)

I had uTorrent installed on my computer, which I believe started the problems in the first place. Some browser viruses seemed to have got installed due to which Google Chrome was acting weird. An MPC Player / Cleaner got installed automatically. So, to avoid any further damage, I decided to reinstall Windows. I had the installation files on a Sandisk ULTRA 32GB flashdrive. I booted from the flashdrive and tried to install Windows. At the partition screen, it gave me the message "Windows Cannot be Installed to Disk 0 Partition 1". This error message was flashed for all the partitions. I had only one disk i.e. Disk 0. So, I formatted the C:drive (drive size ~150GB) and reallocated by creating a NEW drive and tried to install again but i got the same error message. So, I decided to do formatting through DISKPART (which again I was using for the FIRST TIME) (attchmt: screenshot 1). I listed the disk, selected disk 0 and the BIG MISTAKE happened - I accidentally typed CLEAN command and hit Enter. The entire Disk 0 was cleaned completely.

So, I began researching on the Internet for recovery tools and methods. I came across TestDisk and my friend confirmed it is one of the best tools for recovery. Now, I have NOT installed anything on the 1TB HDD after the cleaning.

I formatted 32GB Flashdrive I had and installed Windows 8 64 bit ON THE FLASHDRIVE using WintoUSB to get access to the 1TB HDD. I booted the laptop from the flashdrive which is working fine. The following drives have been created - C: drive (13.9GB) and D: drive (28.6GB) (attchmt: screenshot 2). I installed TestDisk 7.0 and ran it.

I used the following reference links for steps -

http://www.cgsecurity.org/wiki/TestDisk_Step_By_Step


Step-by-step :

1) Log creation

Worked fine


2) Disk selection

Showed me the HDD 1000GB / 931GB. So hope it was fine too.


3) Partition table type selection

It automatically selected Intel. so, should be fine i suppose.


4) Current partition table status PROBLEM

After i ran Analyse, It gave the error - "Partition sector doesn't have the endmark 0xAA55"

So, assuming that partition structure was lost and to retrieve the lost partitions i ran the Quick Search to proceed.

5) Quick Search for partitions

It returned a few partitions

6) Save the partition table or search for more partitions?

Since all the partitions were not showing up, i went for the Deeper Search

7) A partition is still missing: Deeper Search

I ran the Deeper Search option 3 times to ensure each and every file and folder is retrieved. Luckily, all the partitions showed up. (attchmt: screenshot 3) but ALL of them were marked D which indicated Deleted.
First Deeper Search took about 4 hours to complete. Second and third Deeper Search action took more than 2 hours.

I checked the partitions and found the 2 CORRECT Partitions I want to recover. They have all the folder and files listed inside. (attchmts: screenshot 4 and screenshot 5)

I DONT CARE about any other partitions listed here including the boot sector partition of windows if any. I just want to recover these 2 partitions which has my very important Data (both these partitions' data does NOT have any other backup, so I desperately need it back.

Now, as indicate in the TestDisk_Step_by_Step, I tried to change the status of the selected partition from D(deleted) to L(logical). It allowed me for the last partition (423GB / 394GB). But if i try to change the status of the next selected partition from D to L, it gives me " Structure: Bad ". So, basically, it does NOT allow me change status of both partitions to L(logical) SIMULTANEOUSLY.

ALL my partitions have been showing a D(Deleted) status after the Analyse results.
BOTH the partitions are very important for me and need to be recovered.

So, now i tried if other P(primary) status change is being allowed. Maximum it allows me ONLY EITHER of the two desired partitions to be labelled as L(logical) at any given moment. If i choose L(logical) for BOTH simultaneously, it gives the Structure: Bad error. So, i tried to make both the desired partitions as P(Primary) and it allows me, and I decided to add another partition as P(primary) too. (attchmt: screenshot 3)

8) Partition table recovery PROBLEM

With 3 partitions selected as P(primary) and rest as D(Deleted) (attchmt: screenshot 3), all partitions listed, I proceeded to WRITE with Enter, Y and OK.
It returned an error - Partition Write Error

So, I did all the above again and now have all the partitions listed again. The two desired partitions are listed as before and still have the folders and files that I need to recover. It still gave me the error "Partition sector doesn't have the endmark 0xAA55" which I ignored and went ahead to analyse and found all the partitions. (attchmt: Screenshot 6)

I am sure I am overlooking something. I need your help to recover these TWO partitions and the every single data in them. PLEASE HELP and suggest.
Attached all screenshots
Attachments
TestDisk - Screenshots.zip
(162.03 KiB) Downloaded 49 times

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3555
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Partition sector doesn't have the endmark 0xAA55 + Partition Write Errors- Need help

#2 Post by cgrenier » 22 Jul 2016, 13:16

Logical partitions need at least one free sector between them.
Set the partitions you want to recover as P(rimary).

If you still get a write error message when rewriting the partition table, you may have to start your windows in safe mode and disable your antivirus.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest