Read Error during testdisk

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 2
Joined: 17 Aug 2016, 17:36

Read Error during testdisk

#1 Post by elbabu »

Hello to everyone, I'm new in this wonderful forum.
I'm trying to recover my Seagate internal hd, it was mounted in my laptop.
Laptop can't boot so I decided to put the hd in my usb/sata adapter and trying to recover by another pc.
In windows I can see the device but I can't open it. If I do so, it ask me to format it...if I choose yes it told me "impossible to format".
I run testdisk and in the dos window I can see:
" Drive G: - 310GB / 289GiB - CHS 37765 255 63
Analyse cylinder 744/37664: 01%
Read error at 780/243/40 (lba=12031072)

There is another partition (empy) in the disk, that has no problem.

Thanks who wants help me.

Sponsored links

User avatar
Site Admin
Posts: 5307
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: Read Error during testdisk

#2 Post by cgrenier »

Its a bad idea to try to format a partition when you want to recover data...
Try PhotoRec on this disk. Once the data have been recovered, use the warranty/try to replace the disk.

Posts: 2
Joined: 17 Aug 2016, 17:36

Re: Read Error during testdisk

#3 Post by elbabu »

Thanks for you reply cgrenier, I Know is not a good idea format the hd, but any else action gave me results.
The problem is that I don't see the partion.