Testdisk stuck after copying ~ 35G of ~ 400G folder - exfat_ucstoutf8: iconv failed Invalid or incomplete multibyte...

How to use TestDisk to recover lost partition
Post Reply
Message
Author
chrisco23
Posts: 1
Joined: 26 Aug 2016, 23:21

Testdisk stuck after copying ~ 35G of ~ 400G folder - exfat_ucstoutf8: iconv failed Invalid or incomplete multibyte...

#1 Post by chrisco23 » 26 Aug 2016, 23:40

Symptom: Only errors in my log file look like this:

Code: Select all

exfat_ucstoutf8: iconv failed Invalid or incomplete multibyte or wide character
Can't create file...etc...
The file it's trying to create a copy of appears to have a bunch of character-encoding gibberish at the end of the filename.

I've been using my Seagate Expansion 5TB USB on my Ubuntu desktop for 1 year without fail on Ubuntu 14.04 desktop.

I plugged it into a Windows 10 machine because I wanted a cloned image of it. No drive letter so I ran Disk Management. This showed two "RAW" unallocated partitions, slightly different sizes but close enough to 2.5TB each. I made NO changes. I looked for an option to assign a drive letter but I didn't find so I made no changes.

I plugged it back into my Ubuntu machine and it could not mount. Testdisk immediately found my single exfat partition and showed what appeared to be all my files (I didn't try to traverse directories).

I started copying the very most important directory. The past ~ 2 hours it's been stuck it's been stuck like this:

Code: Select all

   P exFAT                    0   0  1 608001  80 62 9767541167
Directory /
Copying, please wait... 6011 ok, 131 failed
A tail on the log is not growing. The testdisk process is in "D" (unrecoverable sleep) status. The 5TB drive light is flashing.
Naturally I can't change any filenames since I can't mount.
I don't care at all about the particular directory it seems to have had trouble with.
I don't want to try to stop and restart because I can't determine what sort of recursion it's been doing.
How can I make progress?

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3626
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Testdisk stuck after copying ~ 35G of ~ 400G folder - exfat_ucstoutf8: iconv failed Invalid or incomplete multibyte.

#2 Post by cgrenier » 27 Aug 2016, 07:31

Run "dmesg". Do you see read error messages ?

Restart Testdisk and select another directory to copy it.

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests