Strange external problem

Using TestDisk to repair the filesystem
Post Reply
Message
Author
durfturf
Posts: 4
Joined: 19 Aug 2016, 01:05

Strange external problem

#1 Post by durfturf » 09 Sep 2016, 02:49

Background

Took my ntfs WD My Passport to a friend's place, it wouldn't be recognized even though it was recognized less than an hour ago on my computer. Friend plugged/unplugged w/o ejecting while it was looking for drivers or something. We were not writing/copying data at the time. I run W10/ubuntu my friend runs W7.

Details

W10
The disk shows up on device and disk manager but disk manager now reads the file as unallocated. It even reads the disk as "My Passport" so there is definitely still some kind of data left on there.

Ubuntu
Running under live disk, the disk will only show up under "Disks." It also reads the disk as unallocated. I tried to copy disk as image but it was replacing bad sectors with zeroes and I wasn't sure if it was writing the bad sectors to the disk or to my new external to offload data on.

TestDisk
I've been running it for about 16hrs and it's on sector 264/121596, all with read error. I'm not sure this is the right way to go about it. At this rate it'd take over a 100 days to do a full check. Testdisk can see that it has 931/1000GB in use on the drive so there's something on there it knows so I'm hopeful. What can I do from this situation? Should I just use Photorec to recover files and forget saving the whole disk?

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3765
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Strange external problem

#2 Post by cgrenier » 09 Sep 2016, 06:28

Under Ubuntu, you can try ddrescue to clone the disk to a new empty one or an image file but it looks like there is a serious physical problem. If it works, use testdisk or photorec on the clone.
If it doesn't work, you may have to contact a data recovery company...

durfturf
Posts: 4
Joined: 19 Aug 2016, 01:05

Re: Strange external problem

#3 Post by durfturf » 09 Sep 2016, 09:19

I'm optimistic that it's not a physical problem because there's no unusual sounds coming from the disk and the computer can still detect it's a passport so there's something on there. Even TestDisk can see there's 931/1000 in usage. I'll try photorec.

i'm not as familiar with ddrescue but look into that as well.

Edit: SMART also scans the disk as healthy.

durfturf
Posts: 4
Joined: 19 Aug 2016, 01:05

Re: Strange external problem

#4 Post by durfturf » 11 Sep 2016, 22:08

update:

by some miracle the drive was recognized by windows when I plugged it into the USB. Still couldn't do a chkdsk as the disk was set to read only.

Ran photorec and it seems to have recovered some part of the drive. I have at least some of the files back.

Still looking for solutions on how the disk can be read properly.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests