Recovering Data from 128GB exFAT SD

How to use TestDisk to recover lost partition
Post Reply
Message
Author
4Strings
Posts: 2
Joined: 22 Sep 2016, 20:24

Recovering Data from 128GB exFAT SD

#1 Post by 4Strings » 22 Sep 2016, 20:42

Hi all,
So my sister's 128GB microSD card (formatted as exFAT) got corrupted in her phone and she lost about a month's worth of pictures and videos from our family vacation.

I've tried various programs to try and recover the data, including Photorec, TestDisk, gparted, etc., but none of them seem to work.

When I tried to use Photorec, it managed to recover about 38 files (unfortunately they were only random album art images from the music that was stored on the card), but it took about two days to do that, after which it says that it can't recover any more files and asks if to make an image of the remaining files.
When I try to use TestDisk, it detects the file system as NTFS (not exFAT), and when I go to analyze the disk, it lists all of the folders in to root directory (which windows does too) but when you view any of the folders, they are empty and TestDisk gives a message that the file system is corrupted/damaged.

I have tried using both programs on three different computers (one desktop and two laptops) and an additional weird thing is that when I put the SD card into the built-in card reader of any of the laptops, no data or filesystem is detected at all by either TestDisk or Photorec, but when I use a USB3.0 card reader, on any of the computers, the (incorrect) NTFS partition is detected by both programs.

In addition, I tried to use gparted to boot one of the computers into linux and try to recover the files that way, but while it does recognize the SD card as formated with exFAT, after a Deep Search it says that no filesystem data was found.

I know the files are still there because Windows Explorer, Windows Disk Manager, TestDisk, Photorec, and gparted all show 119GB used out of 127GB.


I'm really at a loss as to what to do next in order to try to recover the data from the card, so ANY advise as to what I can do next would be great...
Thanks-in-advance,
-4Strings

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3565
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Recovering Data from 128GB exFAT SD

#2 Post by cgrenier » 23 Sep 2016, 05:59

Try again PhotoRec but choose Whole instead of Free after selecting the partition and choosing Search.

4Strings
Posts: 2
Joined: 22 Sep 2016, 20:24

Re: Recovering Data from 128GB exFAT SD

#3 Post by 4Strings » 23 Sep 2016, 06:24

I have tried selecting both Whole and Free after selecting the partition. Free never found any files and Whole only found the 38 files before stopping.

Thanks,
- 4Strings

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest