Recover/repair external harddrive NTFS

How to use TestDisk to recover lost partition
Post Reply
Message
Author
ly2y
Posts: 2
Joined: 28 Sep 2016, 18:40

Recover/repair external harddrive NTFS

#1 Post by ly2y » 28 Sep 2016, 18:55

So I can't access my external harddrive, and looking at it from the Windows control panel its data system is RAW, however I recently (like two weeks ago) changed it from fat32 to NTFS
Its capacity is 500gb, and around 350gb of it is used. I need the data for a project for work, and while I could get hold of it in another way, that would be very inconvenient

So I was wondering how to recover those files and maybe repair the hard drive so I can use it again
The drive in question is E:

Image

I searched a bit online and it seems testdisk is a good utility to handle such an issue, however I have not found a guide or some help on my specific problem that could help me solve it
I ran testdisk, selected Create new log file, chose E:, then chose Intel and then Analyze. It comes up with this screen:

Image

What should I do here? Any help would be greatly appreciated

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3553
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Recover/repair external harddrive NTFS

#2 Post by cgrenier » 28 Sep 2016, 21:01

It's useless to search partitions inside a partition.

Run TestDisk, select the PhysicalDrive containing E:, not E: itself, Advanced, select the partition, Boot, RebuildBS, List.
If you can see your files, choose Write, confirm, Quit

ly2y
Posts: 2
Joined: 28 Sep 2016, 18:40

Re: Recover/repair external harddrive NTFS

#3 Post by ly2y » 28 Sep 2016, 22:28

I see. Thank you for the fast answer.

I did as you said, but there is no write option after RebuildBS/List:

Image


Edit: It does list the correct files by the way

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests