What to do with a huge .gz file?

Using PhotoRec to recover lost data
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Posts: 2
Joined: 07 Dec 2016, 20:21

What to do with a huge .gz file?

#1 Post by zhalberd »

Hi there. Thank you for this software. It's saved me a few times in the past.

I recently formatted an SD card in-camera using the Sony A7S Mark II. I was recording 4k video using the XAVCS format. It was about 60GB worth of data :-(.

I used PhotoRec and did a [Whole disk] scan and it recovered some files. All of the files are sub 10MB except for one which is 59GB in size. It's a .gz file. I've used 7ZIP to try to unarchive this file, but nothing seems to happen.

Do you have any advice on what to do with this file or if in fact I'm going about this recovery in the wrong way?

Thank you for your time. I've donated before as I think this software is a huge service to the community.

Sponsored links

User avatar
Site Admin
Posts: 5304
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: What to do with a huge .gz file?

#2 Post by cgrenier »

Do you have a small unmodified video taken with your camera ?
I will check if PhotoRec recognize this format or not.

Mac OS X creates files index using sqlite database file and compressed data using gzip. When PhotoRec doesn't detect the end of the file, it results in huge files.

Posts: 1
Joined: 29 Dec 2017, 12:16

Re: What to do with a huge .gz file?

#3 Post by bvouzella »

I have exactly the same problem here: formatted the 64gb card by mistake, in the camera menus (Sony a6500 camera).
I was also using the camera to record mp4 videos, in the same format as zhalberd mentioned.

Tried using photorec in MacOS 10.12.6 to try to recover the files.
Ended up with a some nice jpgs and a 64gb .gz file whose contents I can not decompress. Tried by MacOs Archive Utility and also by the Unarchiver app. Both showed error messages. (see attached files)

Is it possible that any of my files are compressed in this gz? Or is it just a corrupted file?

I have uploaded a sample 1s video taken with the camera in this link:
https://drive.google.com/file/d/1RF1LET ... sp=sharing
Screen Shot 2017-12-29 at 09.25.16.png
Screen Shot 2017-12-29 at 09.25.16.png (42.29 KiB) Viewed 1327 times
Screen Shot 2017-12-29 at 09.23.49.png
Screen Shot 2017-12-29 at 09.23.49.png (37.23 KiB) Viewed 1327 times