Rescuing ext4 raid disk

Using TestDisk to repair the filesystem
Message
Author
Benjamin
Posts: 4
Joined: 13 Jun 2012, 00:06

Rescuing ext4 raid disk

#1 Postby Benjamin » 13 Jun 2012, 00:24

Hi, friends in troubles :(

This is my situation:
- two disk setup in softraid on Ubuntu, raid partition was ext4
- after brakedown one disk was unaccessable, raid was running in degradeable state
- despite that I wasn't able to access files (raid refused to mount, disks were busy ... etc), so I tried different solutions (I was not aware of testdisk at the time)
- once I started fsck.exe4 and got some errors, I think there was something cleared (??? I don't remember after everything I already tried)
- after a while disk was online again but some important folders were missing, of course I made a copy of existing files

But how to get lost folder? I am running photorec now to recover files, but it will take a day or two to finish. What worries me is that I mostly get jpgs (they are mostly fine) and many useless .txt files. Important files like Photoshop .psd and InDesign .indd are corrupted.
Should I use testdisk instead photorec? How - I don't get undelete options, I can only see partition.

Thanks, I would appreciate any help-

Sponsored links

Benjamin
Posts: 4
Joined: 13 Jun 2012, 00:06

Re: Rescuing ext4 raid disk

#2 Postby Benjamin » 14 Jun 2012, 09:19

I made another try with testdisk and corrupted disk connected to Ubuntu (previously Windows).
I got 3 'versions' in disk list - two raid (md0 and md0p1) and one with phisical disk description (WDC 1002EA ...something). So far md0 gave best results, but:

Screenshot from 2012-06-14 07-29-50.png
Problem with heads per cylinder
Screenshot from 2012-06-14 07-29-50.png (50.54 KiB) Viewed 948 times


After quick search I get list of files with the missing folder (highlighted) but is different from other files - why?

Screenshot from 2012-06-14 07-27-20.png
Highlighted line is the missing folder
Screenshot from 2012-06-14 07-27-20.png (107.06 KiB) Viewed 948 times


Of course I tried to copy it without success. Now I'm running deeper search.

Ben

PS: Is this topic in proper forum?


Return to “Filesystem repair”

Who is online

Users browsing this forum: No registered users and 0 guests