Lost partition couldn't find after analyse

How to use TestDisk to recover lost partition
Post Reply
Message
Author
SkuterPL
Posts: 12
Joined: 26 Feb 2013, 18:58

Lost partition couldn't find after analyse

#1 Post by SkuterPL » 06 Apr 2017, 08:13

Hi,
I have problem with my HDD, because I couldn't find my partition to recovery, in testDisk I see
Przechwytywanie2.PNG
Przechwytywanie2.PNG (11.93 KiB) Viewed 450 times
, but in disk menager this:
Przechwytywanie.PNG
Przechwytywanie.PNG (12.16 KiB) Viewed 450 times
There is any way to fix my disk without deleting files?

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3629
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Lost partition couldn't find after analyse

#2 Post by cgrenier » 07 Apr 2017, 18:45

If your disk does some unusual noises, a disk head is probably damaged, you should in this case contact a data recovery company.
Otherwise if the problem is due to bad sectors, you should clone the disk to a new empty one using ddrescue from a Linux LiveUSB/LiveDVD as described in https://www.cgsecurity.org/testdisk.pdf
Good luck

SkuterPL
Posts: 12
Joined: 26 Feb 2013, 18:58

Re: Lost partition couldn't find after analyse

#3 Post by SkuterPL » 07 Apr 2017, 19:05

It's external HDD, but I don't hear any strange noisy, but normally, so in Windows testTidsk I can't do anything else?

User avatar
cgrenier
Site Admin
Posts: 3629
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Lost partition couldn't find after analyse

#4 Post by cgrenier » 09 Apr 2017, 11:05

ddrescue under Linux is far better than dd for windows to clone damaged disk, so you really should boot from a Linux LiveUSB.
It's not so difficult.

SkuterPL
Posts: 12
Joined: 26 Feb 2013, 18:58

Re: Lost partition couldn't find after analyse

#5 Post by SkuterPL » 10 Apr 2017, 10:42

I see, I will try this way, but for sure I need 2nd HDD with space of broken drive to clone it?

SkuterPL
Posts: 12
Joined: 26 Feb 2013, 18:58

Re: Lost partition couldn't find after analyse

#6 Post by SkuterPL » 24 Apr 2017, 14:08

Hi again,
Finally I bought second HDD on which I want to clone my broken HDD. I opened Ubuntu live and started this commend

Code: Select all

 ddrescue --force /dev/sdb /dev/sdc sdb.log
I had to use FORCE, because without it I cannot start cloning process.

Now it's coping very slow and shows me errors in window of DDRESCUE:

https://www.dropbox.com/sh/0y5u9po7ojd1 ... qYyFa?dl=0

Here you can see short movie which shows that black hard drive (that's broken) all time LED is enabled, but on the new one (white) is blinking (just like in coping process), so why black one isn't blinking?

I don't know if it's sense wait for cloning with error rate, what is it mean?

Regards,
Tomek

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest