PhotoRec (7.0, 7.1) not asking Free or Whole

Using PhotoRec to recover lost data
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 1
Joined: 09 Jun 2017, 14:17

PhotoRec (7.0, 7.1) not asking Free or Whole

#1 Post by pteittinen »


I'm trying to recover deleted files from a 10TB Raid-6 array on a Qnap TS-869 Pro NAS box. I've tried PhotoRec versions 7.0 and 7.1 beta; neither asks if it should analyze only Free space or the Whole partition. Instead both start analyzing the Whole partition which looks like it would take approx. 100 hours.

Am I missing something, or could there be something in the partition that prohibits analyzing Free space only? PhotoRec reports the partition as "P Linux LVM2".


Sponsored links

User avatar
Site Admin
Posts: 5307
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: PhotoRec (7.0, 7.1) not asking Free or Whole

#2 Post by cgrenier »

PhotoRec doesn't ask Free or WHole because it's not an ext2/3/4... filesystem.

A disk contains several partitions, some of them may be LVM Physical Volume (PV).
PV are grouped in Volume Group (VG). VG are splited in Logical Volume (LV).
Each LV is formated (ext2/3/4, xfs...)

Your disk is using LVM, so you should boot from a Linux LiveUSB, use "pvdisplay", "vgdisplay", "lvdisplay"... and mount the logical volume or use PhotoRec on the logical volume instead of working on the physical volume.