Micro SD Card Samsung 64GB Evo SDXC - RAW

How to use TestDisk to recover lost partition
Post Reply
Message
Author
rmmb
Posts: 2
Joined: 12 Jun 2017, 10:41

Micro SD Card Samsung 64GB Evo SDXC - RAW

#1 Post by rmmb » 12 Jun 2017, 11:16

Hi,

Android stopped recognizing this card (used in my Android phone for Images and Video mainly) and wanted a format. I tried W10 and the same happened. I used CHKDSK /F /R but after some operations the result was a RAW card.

Now I'm using TestDisk to try to recover this card. I checked the documentation and learned that there is a "Backup boot sector" that can be used to recover the "Boot Sector". In my case both are BAD. See below. Should I use Rebuild BS? Is there another option to get access to the files saved in the SD Card?

TestDisk 7.1-WIP, Data Recovery Utility, May 2017
Christophe GRENIER <grenier@cgsecurity.org>
http://www.cgsecurity.org

Disk /dev/sdb - 64 GB / 59 GiB - CHS 7785 255 63
Partition Start End Size in sectors
1 * FAT32 LBA 0 32 33 7785 19 42 125065216

Boot sector
Bad

Backup boot sector
Bad

First sectors (boot code and partition information) are not identical.
Second sectors (cluster information) are not identical.

A valid FAT Boot sector must be present in order to access
any data; even if the partition is not bootable.


Thanks,

Rui

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3619
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Micro SD Card Samsung 64GB Evo SDXC - RAW

#2 Post by cgrenier » 13 Jun 2017, 06:37

Try RebuildBS, List. If you can see your files, choose Write, confirm, Quit

If it doesn't work, use PhotoRec instead.
Good luck

rmmb
Posts: 2
Joined: 12 Jun 2017, 10:41

Re: Micro SD Card Samsung 64GB Evo SDXC - RAW

#3 Post by rmmb » 15 Jun 2017, 18:32

Hi. Thank you so much for your support... I have recovered all the files I wanted!

For the record: Rebuild BS didn't work successfully on the SD Card and I have used Qphotorec after that. I had to stop the process after 7 hours! But I could see that it worked very well. So I restarted the process, but this time I filtered to recover only the images (JPG files) et voilá all my images recovered after just 1 hour.

Now the strangest part. I tried CHKDSK /F /X /R again on the card and to my surprise CHKDSK worked and apparently repaired the SD card. But there was a problem with permissions and file access. I tried to give the right permissions and the SD card is RAW again. But that's ok! I've got my files!
:D

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests