500gb hdd showing no partitions + partion: read error

How to use TestDisk to recover lost partition
Post Reply
Message
Author
snomang
Posts: 1
Joined: 13 Jun 2017, 20:46

500gb hdd showing no partitions + partion: read error

#1 Post by snomang » 13 Jun 2017, 21:16

Hello everyone, this is my first post here so forgive any rookie forum faux pas. So, I didn't drop this drive or anything -- it just failed to wake up from sleep one day and kept looping thru the post test never making it any Windows 7 splash page. It's Win 7, 500GB HDD, and when plugging it into another Windows or Linux machine shows the drive as uninitialized/unallocated. So I've run a quick scan on it using TestDisk. Before running the scan it had said Partition: Read Error, and during the scan it flagged every cylinder/sector/whatever with this Read Error. Quick scan didn't find any partitions. I ran CrystalDiskInfo and it's showing as "Good" (I can post a screenshot if needed). Scanned it with Partition Find & Mount, but it found no partitions even with it's deep scan. I also ran a scan with Minitool Partition Wizard just to see if it found anything, and it did find the partition, but I'd like to exhaust other options before buying a 1 PC license -_- ... Anyway, any help would be appreciated, thanks!

Here is the log of my TestDisk Quick Scan (I accidently started another after scan and cancelled right away, so that may be the "Search for partition aborted", I'm not sure):


Tue Jun 13 14:59:54 2017
Command line: TestDisk

TestDisk 7.1-WIP, Data Recovery Utility, May 2017
Christophe GRENIER <grenier@cgsecurity.org>
http://www.cgsecurity.org
OS: Windows 8 (9200)
Compiler: GCC 5.4, Cygwin32 2005.2
ext2fs lib: 1.43.1, ntfs lib: 10:0:0, reiserfs lib: none, ewf lib: 20140608, curses lib: ncurses 6.0
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sda)=500107862016
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sdb)=250059350016
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive0)=500107862016
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive1)=250059350016
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\C:)=465914822656
filewin32_getfilesize(\\.\D:) GetFileSize err Incorrect function.

filewin32_setfilepointer(\\.\D:) SetFilePointer err Incorrect function.

Warning: can't get size for \\.\D:
Hard disk list
Disk /dev/sda - 500 GB / 465 GiB - CHS 60801 255 63, sector size=512 - WDC WD5000AZLX-08K2TA0, S/N:WD-WCC6Z4PJFKK9, FW:01.01A01
Disk /dev/sdb - 250 GB / 232 GiB - CHS 30401 255 63, sector size=512 - WDC WD25 00YS-23SHB0, S/N:A2800000000000000000, FW:20.0

Partition table type defaults to Intel
Disk /dev/sdb - 250 GB / 232 GiB - WDC WD25 00YS-23SHB0
Partition table type: Intel

Analyse Disk /dev/sdb - 250 GB / 232 GiB - CHS 30401 255 63
Current partition structure:

Partition: Read error

search_part()
Disk /dev/sdb - 250 GB / 232 GiB - CHS 30401 255 63
file_pread(5,16,buffer,32(0/0/33)) ReadFile Data error (cyclic redundancy check).

file_pread(5,3,buffer,48(0/0/49)) ReadFile Data error (cyclic redundancy check).

file_pread(5,3,buffer,95(0/1/33)) ReadFile Data error (cyclic redundancy check).

file_pread(5,8,buffer,111(0/1/49)) ReadFile Data error (cyclic redundancy check).

file_pread(5,11,buffer,158(0/2/33)) ReadFile Data error (cyclic redundancy check).

file_pread(5,2,buffer,2080(0/33/2)) ReadFile Data error (cyclic redundancy check).

file_pread(5,2,buffer,51(0/0/52)) ReadFile Data error (cyclic redundancy check).

... (This went on for many lines so I'll skip to the end) ...

file_pread(5,8,buffer,488396878(30401/76/26)) ReadFile Data error (cyclic redundancy check).

file_pread(5,11,buffer,488396925(30401/77/10)) ReadFile Data error (cyclic redundancy check).

file_pread(5,2,buffer,488398847(30401/107/42)) lseek err Invalid argument
Search for partition aborted

Results

interface_write()

No partition found or selected for recovery
simulate write!

write_mbr_i386: starting...
file_pread(5,1,buffer,0(0/0/1)) ReadFile Data error (cyclic redundancy check).


Partition: Read error
Store new MBR code
write_all_log_i386: starting...
No extended partition

TestDisk exited normally.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3615
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: 500gb hdd showing no partitions + partion: read error

#2 Post by cgrenier » 14 Jun 2017, 13:25

There are bad sectors, so you should to clone the disk to new empty one using ddrescue.
Read https://www.cgsecurity.org/testdisk.pdf chapters "DDRescue: data recovery from damaged disk" and "Creating a live USB".
Once it's done, remove the original disk and try to recover your data from the clone.

If nothing can be read successfully, it may be a problem of damaged head, in this case, you should contact a data recovery company.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests