Photorec gets stuck in sector-reading loop when run on whole drive

Using PhotoRec to recover lost data
Post Reply
Message
Author
Hashim
Posts: 6
Joined: 12 Aug 2017, 00:41

Photorec gets stuck in sector-reading loop when run on whole drive

#1 Post by Hashim » 08 Sep 2017, 23:03

Hi.

I accidentally ran...

Code: Select all

diskpart
format override /fs=ntfs
...on my 2TB external hard-drive. The format only lasted for a few seconds before I stopped it with Ctrl+C, but it was enough to make the drive unavailable to Explorer and lose my partition tables. The drive must have been really fragmented, because after many months of trying different partition recovery softwares, including Testdisk, I've still been unable to recover my partitions. Because of this, I'm forced to use Photorec.

However, the problem I'm having with Photorec is that when I attempt to use it to recover the contents of my whole disk, it eventually gets stuck in an infinite loop. The last time I ran it the sector would go up to roughly 357,000,000 and then start again at 209,000,000, and so on. Running a capture program showed me this happened every 2 hours or so, and each time it did the ETA would rise. When I eventually stopped it, Photorec had run for over 100 hours and still was projecting 1000+ remaining.

I'm currently trying the "Partition only" option instead of the full drive, but because of the corruption on my drive I don't have much confidence it will restore all or even most of my files.

Sponsored links

Marty
Posts: 2
Joined: 18 Sep 2017, 18:34

Re: Photorec gets stuck in sector-reading loop when run on whole drive

#2 Post by Marty » 18 Sep 2017, 18:56

I am having the same issue.
A few days ago, I tried to recover the files from my 1TB WD external drive with PhotoRec, but it's stuck in a loop.
It reads up to about 285 million sectors (14%) and then goes back to 260 million (13%).
It went up to 14% in a matter of 4-5 hours, but it keeps falling back to 13%. This happens every 30 minutes and has been going on for nearly a week now.
And looking at what's been recovered, since it got stuck in the 13%-14% loop, it's only been recovering the same files over and over again.
It did recover at least 50GB of files that I didn't want to lose (It recovered up to 110GB, but I'm not sure how much of it is a duplicate from the 13-14% loop), but I'm still missing a few 100GBs.
Is there are a way to bypass and ignore the sectors it can't read?

Thank you

-Marty

User avatar
cgrenier
Site Admin
Posts: 3615
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Photorec gets stuck in sector-reading loop when run on whole drive

#3 Post by cgrenier » 19 Sep 2017, 20:23

Are you using PhotoRec 7.1-WIP or an older version ?
If you are using an older version,
Under PhotoRec, choose Stop, Quit.
Download latest testdisk 7.1-WIP.
Copy the photorec.ses file from the old directory to testdisk-7.1-WIP directory
Run PhotoRec and choose to resume the recovery.

If you are already using PhotoRec 7.1-WIP.
Under PhotoRec, choose Stop, Quit.
Backup the photorec.ses file.
Edit photorec.ses file with wordpad or notepad++.
Remove the unwanted sector range.
Run PhotoRec and choose to resume the recovery.

Marty
Posts: 2
Joined: 18 Sep 2017, 18:34

Re: Photorec gets stuck in sector-reading loop when run on whole drive

#4 Post by Marty » 15 minutes ago

cgrenier wrote:
19 Sep 2017, 20:23
If you are already using PhotoRec 7.1-WIP.
Under PhotoRec, choose Stop, Quit.
Backup the photorec.ses file.
Edit photorec.ses file with wordpad or notepad++.
Remove the unwanted sector range.
Run PhotoRec and choose to resume the recovery.
I'm using qPhotoRec 7.1-WIP.
I removed all lines containing the sector range (260mil to 285mil)
Am I supposed to remove the last line that says something like "285.000.000 - 1.953.458.178" or should that one stay?
Also, I don't see any option to resume the recovery in qPhotoRec. Is that only an option in the text-only PhotoRec?

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest