Seagate 2TB External HDD under none

Using TestDisk to repair the filesystem
Post Reply
Message
Author
id104335409
Posts: 2
Joined: 14 Sep 2017, 11:38

Seagate 2TB External HDD under none

#1 Post by id104335409 » 14 Sep 2017, 11:42

I have no technical knowledge about HDDs, but I do OK with my problems. This is something that I can't fix on my own.
I have a 2TB Seagate External HDD full with video files. The MBR on it went corrupt and the file system was lost. It became unreadable by Windows. Windows want to format it, me - no way!

I can recover the files with Recuva or EaseUS recovery. All files and folders are visible there. But That would mean I have to buy another 2TB drive just for that file transfering and then be left with a clean empty HDD. Seems like a waste of time and money. Yes - it is a good idea to have the new drive as backup, since the old one is now unreliable, but cash is scarce. I was wondering why can't files be restored by restoring the table instead of rewriting the files. Wouldn't this be the ideal go-to solution? And if it exist as an option why isn't it the first thing that Windows should try to do instead of just advising users to format? It seems silly to me that files that are still on the drive and can easily be recognised and copied need to be transfered somewhere else first, when you could just rewrite the information about them. Sorry if I don't make any sense or lack a better understanding of how things work.

I decided to try recovering the MBR and filesystem with the hopes of getting the files back on the same drive. I tried TestDisk, but these are the results.
if:

I chose "None" for Nonpartitioned media, analyse partition structure
NTFS partition found Drive F - 2000GB highlighted in green
Structure OK, P - list files = Can't open filesystem. Filesystem seems damaged.
Write isn't available, because the partition table type "None" has been selected.

I chose "Intel/PC" partition, analyse partition structure
TestDisk goes directly into deep search, it takes about 3 - 4 hours
2 FAT and 2 NTFS patitions found, 3 of which are old and one is the current full size. None of them are highlighted in green.
There is a warning sign that all partitions together are bigger than the drive.
Can't read files. None of the partitions can be restored.
Write isn't available. There is only continue.

I tried chkdsk before anything else, but it fails to start.

I was hoping I can use TestDisk to fix the drive, but if that isn't possible maybe you can give me some pointers about what happened and what I could try to do next. Or maybe there is something that could still try with TestDisk and I just don't know about it.
Thank you!

I am reading trough your forum right now to get more info on what can and can't be done.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3754
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Seagate 2TB External HDD under none

#2 Post by cgrenier » 15 Sep 2017, 07:08

It's useless to search partitions inside a partition (F: in your case).

Read https://www.cgsecurity.org/testdisk.pdf chapter "Repairing filesystem" and post the results if you have problems.

id104335409
Posts: 2
Joined: 14 Sep 2017, 11:38

Re: Seagate 2TB External HDD under none

#3 Post by id104335409 » 16 Sep 2017, 12:17

I followed chapter 7.6 TestDisk: Repairing NTFS boot sector last night.
After choose Boot TestDisk started to check MFT (I din't click on such option, I clicked rebuild). It worked trough the night and the middle of the next day. I don't mind.
But then I had this message:
Boot sector OK
Backup boot sector OK
Sectors are identical
A valid NTFS boot sector must be present in order to access any data.

Listing files still doesn't work however. Rebuild BS sends me back to checking MFT. I canceled that.
While repair MFT shows this message:
MFT and MFT mirror are bad. Failed to repair them.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests