PhotoRec will not recover openoffice (ods, odt) type of files

Using PhotoRec to recover lost data
Post Reply
Posts: 1
Joined: 27 Mar 2017, 21:16

PhotoRec will not recover openoffice (ods, odt) type of files

#1 Post by killerog13 » 25 Sep 2017, 07:22


A few months ago my usb-stick crashed, from which I was working way too much when I was on the road and that didn't get backed up often enough.

So when this happened I tried to recover this with tools from the UBCD like PhotoRec. Overall PhotoRec did a great job recovering files, but only there wasn't a single open office file among them. As I almost only use open office (libre office to be precise) docs for the stuff I need to do it was a bit odd as there were over 300 of them.
I read on your docs that they might get restored as zips, but there was only one zip that was actually an open office file and that was a template that came with the open office portable edition that I had installed.

I tried a few of my files that were in the old backup on: and they were actually recognized. Then I noticed that the version in UBCD wasn't the latest PhotoRec, so I ran the newer version on windows but got no significant differnces. I tried runs with all the file types checked, or only the open office types checked but no open office files found.

Am I doing something wrong? Or could it be that there might be a bug on recovering these type of files?

Sponsored links

User avatar
Site Admin
Posts: 3691
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: PhotoRec will not recover openoffice (ods, odt) type of files

#2 Post by cgrenier » 26 Sep 2017, 06:47

Do you see your files if you use TestDisk, Advanced, List ? If it's thase case, use testdisk to copy them on another disk.
If it doesn't work, use PhotoRec but choose [Whole] instead of [Free] after selecting the partition.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests