TestDisk finds no partition and lots of read errors on WD MyPassport 1TB

How to use TestDisk to recover lost partition
Post Reply
Message
Author
moconnell
Posts: 1
Joined: 27 Jan 2018, 21:53

TestDisk finds no partition and lots of read errors on WD MyPassport 1TB

#1 Post by moconnell » 27 Jan 2018, 22:16

I have a WD My Passport 1TB USB drive which used to be un-encrypted with a lot of photo backups on it. Now it always prompts for a password which we never set up.

I suspect the main partition information is missing somehow, and as a fallback shows the other partition with WD's security software on it.

I was recommended to try TestDisk, and I let is to a deep scan but it found no partition information and gave lots of read errors. Here is the last few from the log:

Code: Select all

file_pread(6,11,buffer,651454(318/5/31)) read err: Input/output error
file_pread(6,2,buffer,653376(319/2/1)) read err: Input/output error
file_pread(6,1,buffer,653311(318/63/32)) read err: Input/output error
file_pread(6,14,buffer,653314(319/0/3)) read err: Input/output error
file_pread(6,3,buffer,653328(319/0/17)) read err: Input/output error
file_pread(6,3,buffer,653375(319/1/32)) read err: Input/output error
file_pread(6,8,buffer,653391(319/2/16)) read err: Input/output error
file_pread(6,11,buffer,653438(319/3/31)) read err: Input/output error
file_pread(6,2,buffer,655360(320/0/1)) read err: Input/output error
file_pread(6,1,buffer,1953456127(953835/63/32)) read err: Input/output error
file_pread(6,1,buffer,1953456128(953836/0/1)) read err: Input/output error
file_pread(6,14,buffer,1953456129(953836/0/2)) read err: Input/output error
file_pread(6,3,buffer,1953456143(953836/0/16)) read err: Input/output error
file_pread(6,3,buffer,1953456190(953836/1/31)) read err: Input/output error
file_pread(6,8,buffer,1953456206(953836/2/15)) read err: Input/output error
file_pread(6,11,buffer,1953456253(953836/3/30)) read err: Input/output error
Search for partition aborted
What do you guys recommend I try next?

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 4123
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: TestDisk finds no partition and lots of read errors on WD MyPassport 1TB

#2 Post by cgrenier » 28 Jan 2018, 11:27

Contact WD, it's probably a know problem, they may have a solution.

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 0 guests