Erased partition on Mac using disk utility by mistake

How to use TestDisk to recover lost partition
Post Reply
Message
Author
jwpcxs
Posts: 1
Joined: 15 Mar 2018, 17:18

Erased partition on Mac using disk utility by mistake

#1 Post by jwpcxs » 15 Mar 2018, 17:32

Hi Everyone,
I know this story sounds the same as everyone else and I have searched but I cannot seem to find how to fix my problem:

I erased a partition using disk utility on my mac thinking I had a backup of it.
I tried using test disk for over a week now and I still can't figure it out.
I even tried the suggestion of Repair a Mac OS X HFS+ Partition table and then ran test disk again.
I un mounted all partitions and I am trying the disc image copy option (the erased partition) to an external. Is this correct?

I don't see the following menu from another post.
run TestDisk, Advanced, Boot, RebuildBS, List and if you can see your files, choose Write, confirm

When I click advanced, there is no "Boot" option

Thank you in advance
jon

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 4112
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Erased partition on Mac using disk utility by mistake

#2 Post by cgrenier » 16 Mar 2018, 06:55

"Advanced, Boot, RebuildBS" is to repair FAT, exFAT or NTFS filesystem, for HFS+, it's Superblock, but from your problem description, you are not in the case of damaged filesystem.
If it's a problem of deleted partition, TestDisk should recover it after Analyse, Quick Search and if necessary Deeper Search.
If the partition has been reformated, use PhotoRec.

kaneda
Posts: 1
Joined: 02 Apr 2018, 18:04

Re: Erased partition on Mac using disk utility by mistake

#3 Post by kaneda » 02 Apr 2018, 18:06

Hi jwpcxs,
Could you resolve the incident?. I have the same problem but could not recover my lost partition.
Please tell me if you resolve and how.
Thanks in advance.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest