Recovery of HFS partition

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Post Reply
Posts: 1
Joined: 04 Apr 2018, 16:47

Recovery of HFS partition

#1 Post by rtype909 » 04 Apr 2018, 17:03

How I got here

2tb drive, external, HFS single partition was formatted when i as attempting to write an image to a compact flash card via sudo dd command. the image was 300mb.

Drive no longer mounts and i have not attempted to initialize or write to it

Steps taken

I have recovered my files via Photorec.
I have tried testdisk ,to recover the partition via quick search to the raw (rdisk) device but with the details that appear I have attempted to write the correct partition map but it does not work, when checking with pdisk i get 'map is not big enough'

Anything else i can try

Is there way to locate an earlier partition map? or am i going about this entirely the wrong way?

Sponsored links

User avatar
Site Admin
Posts: 4582
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: Recovery of HFS partition

#2 Post by cgrenier » 06 Apr 2018, 06:02

When using TestDisk, use EFI GPT, not Apple partition table.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests