Data partition recovery issues

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 1
Joined: 07 Aug 2018, 16:14

Data partition recovery issues

#1 Post by Gumbo »

Ok so here's the facts.

- 300Gb Hard drive with 20 GB of backed up data on it, on a removable tray on Ubuntu 12.04.
- Need to create a new partition on it, as I need to install Win764 ( to install a specific CAD software which won't run on Linux ) so I fire up Gparted.

- Resized partition with Gparted to 40GB --> OK
- Moved resized 40GB partition to the right of the unallocated space --> Got 4-5 read/write errors during the process but were easily solved by "retry" (got some odd clicking noises at times during the process though).
- Gparted says process completed successfully
- Looks like Gparted is lying to me as the whole disk is now unallocated space. I assume Gparted failed writing the partition table.

So I move on to Testdisk

- The disk is recognized properly (Maxtor 300Gb) and the two partitions (i.e. the partition and the unallocated space) are both recognized
- Unallocated space is suggested as * = bootable (but I don't care)
- Other partition with data on it is suggested as p = logical (the one I care for)
- I select the partition with my data on it, click on write and TestDisk returns a "write error" message. Guess it's failing in writing the partition table, same as Gparted.

Any help in recovering my data would be GREATLY appreciated (possibly the partition as the data were archived in a certain fashion which I need to recover).

My feeling (also due to the clicking noises mentioned earlier), is that the partition with the data on it was moved to the end of the disk where possibly there are damaged sectors, and this may be the reason why both Gparted and Test disk fail in rewriting the partition. This is just my assumption and I am not an expert on this. Matter of fact the issue arose after moving the partition. Wonder if moving the partition to another physical part of the disk before writing the partition table would help, and how to achieve this, if at all possible. No idea if this makes any sense though.

Sponsored links

User avatar
Site Admin
Posts: 5318
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: Data partition recovery issues

#2 Post by cgrenier »

You should clone the disk using ddrescue as described in
Once it's done, remove the original disk and use testdisk on the clone.
Good luck