Incorrect disk capacity

Using PhotoRec to recover lost data
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Post Reply
Message
Author
tuckerkanderson
Posts: 1
Joined: 20 Jun 2019, 00:14

Incorrect disk capacity

#1 Post by tuckerkanderson » 20 Jun 2019, 00:23

Hi everyone.

I recently had a 512GB SSD fail on me. I plug it into my computer and it says "disk unreadable" (Running Mac OS...) I tried it on a PC and it says the drive has malfunctioned. I use the SSD to record raw video files directly from my camera to the ssd (.braw files if it makes a difference...). After shooting some video I unplugged my drive from the camera and into the computer and it gave me the message I described.

I've been trying different recovery methods, but with no success. When I went to use photorec, the note at the bottom of the drive says "Disk capacity must be correctly detected for a successful recovery." But my disk capacity reads 2.1MB when in reality the drive is 512GB. I'm unsure how to check the "HD jumper settings and BIOS detection" as the program says to, so any help would be appreciated. Would really like to get these files back but don't want to pay $1000+ to get them...

Thanks.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 4929
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Incorrect disk capacity

#2 Post by cgrenier » 20 Jun 2019, 05:58

Using the manufacturer tools or hdparm under Linux, try a DCO restore (ie. hdparm --dco-restore /dev/sdb), also check the HPA size (hdparm -N /dev/sdb).
If the disk capacity is still wrong, you really should contact a data recovery company.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest