ext4 directory listed as a file

Using TestDisk to repair the filesystem
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Posts: 1
Joined: 20 Jul 2012, 19:55

ext4 directory listed as a file

#1 Post by acidd22 »

Following a power failure, my large (8TB) ext4 filesystem wouldn't mount. I've been running fsck for a while, but after 2 weeks, it still hasn't completed. When i run testdisk i'm able to find the drive, partition, and see a listing of my files and directories. The probably is that the directory with 95% of my data shows the proper name, but the directory flag isn't there. It shows up as a file. Is there anything i can do about this? Thanks for any suggestions you have!

Sponsored links