filesystem mountable but testdisk claims its defect

Using TestDisk to repair the filesystem
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Post Reply
Message
Author
torwag
Posts: 1
Joined: 26 Jul 2012, 09:29

filesystem mountable but testdisk claims its defect

#1 Post by torwag » 26 Jul 2012, 09:48

Hey,
I had a fatal problem with a HDD. I was able to get an image via dd and can mount it as loop device... however half of the data is gone and I was hopeing to use testdisk to recover some of the deleted data.
Testdisk finds the correct partition however trying to see the files it always tells me that the filesystem seems to be corrupt....
I tried some other disks with completely working and sane partition and file-tables too... always the same problem.

Any ideas?

Again, I can mount the filesystem... partition and filesystem seems to be valid.
Some Metadata
Arch Linux
Ext4
Testdisk version 6.13

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 4390
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: filesystem mountable but testdisk claims its defect

#2 Post by cgrenier » 31 Aug 2012, 14:53

Have you try PhotoRec to see if it recover your files ?

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests