WD 2TB extern - Partition weg, nicht zugeordnet Topic is solved

TestDisk benutzen um verlorene Partitionen wiederherzustellen
Message
Author
ChrisW
Posts: 6
Joined: 08 Mar 2012, 05:28

WD 2TB extern - Partition weg, nicht zugeordnet

#1 Postby ChrisW » 08 Mar 2012, 06:30

Hallo miteinander,

da ich fürchte, dass ich mit meinem Festplatten-Problem (WD20EARS) alleine nicht mehr weiter komme, wende ich mich hoffnungsvoll an dieses Forum ...

kurze Vorgeschichte: Die genannte Platte war ursprünglich in einem My Book USB 3.0 Gehäuse. Da mein Speicherplatz durch PVR (HD)Aufnahmen zunehmend knapper wurde, kaufte ich diese 2TB Platte ... mit Win7 NTFS formatiert, betrieben an USB 2.0 ... Nach und nach wanderten problemlos fast 1,5TB auf die HDD, bis die Übertragungsgeschwindigkeit immer langsamer wurde (z.B. nach schnellem Start beim Verschieben weit unter 1MB/sec) und öfter ganz abbrach. Auch wurde sie beim Anschalten immer später im Arbeitsplatz erkannt, lähmte zeitweise das ganze System v.a. beim Navigieren durch die Ordnerstruktur.

Nun das schwerwiegende Problem:
Da die HDD keinerlei verdächtige Klackgeräusche macht und HD Tune keine Sektoren bemängelte, hatte ich den externen Controller im Verdacht und baute sie vorsichtig in ein anderes USB 2.0/eSATA Gehäuse um. Beim ersten verbinden mit dem PC musste ich die Platte nach der automatischen Treiberinstallation in der Datenträgerverwaltung "initialisieren" (Laufwerksbuchstabe weg, HDD nicht im Arbeitsplatz). Ich wählte "MBR" und seither ist sie hier nur noch als "nicht zugeordnet" zu sehen. Es wird die volle Kapazität angezeigt. Die früher angelegte einzige (primäre) Partition mit den Daten ist verschwunden :|

Nachdem ich mich durch die wirklich hilfreichen Tutorials gelesen hatte, habe ich mich an den Start von TestDisk gewagt, wo die HDD auch mit korrekter Bezeichnung und Größe erkannt wird .Was mir Sorgen bereitet:

1. QuickSearch startete langsam, legte ab ca. 10% deutlich zu und fand auch vereinzelt Read Errors, aber auch bei jetzt 84% wurde noch keine NTFS Partition gefunden, statt dessen beängstigende FAT Meldungen (siehe screenshot)
2. Zudem dauert die "schnelle" Suche nun bereits 15 Stunden an... seit ca. 80% geht es sehr schleppend, das ist doch anderen Berichten zu Folge nicht normal oder? Ich will gar nicht an eine DeepSearch nach NTFS denken :?

Sorry für die langen Ausführungen. Aber ich bin im Moment relativ verzwiefelt. Auf was deutet das alles hin? Und wie sollte ich weiter verfahren? Bin für jeden Experten-Tipp dankbar ...

freundliche Grüße, Chris.

EDIT: :o Wohl zu früh gefreut mit "vereinzelten Read Errors" .. seit einer Stunde hängt die Suche nun bei 85% und es springt von Error zu Error (von Cylinder 206926 bis aktuell 207024). Sollte ich hier abbrechen?
Attachments
TestDisk_Stand_QuickSearch.JPG
Quick Search Stand bei 84%
TestDisk_Stand_QuickSearch.JPG (50.38 KiB) Viewed 3282 times

Sponsored links

User avatar
Fiona
Posts: 2839
Joined: 18 Feb 2012, 17:19
Location: Ludwigsburg/Stuttgart - Germany

Re: WD 2TB extern - Partition weg, nicht zugeordnet

#2 Postby Fiona » 08 Mar 2012, 08:55

Ja, breche ab!
Stress deine Festplatte nicht unnötig!

Die Partition steht normal in der Partitionstabelle.
Die Partitionstabelle 64 Byte ist im MBR.
Nach Wechsel in das andere Gehäuse wurde deine Festplatte nicht erkannt.
Durch Initialisieren, wird eine 4 Byte Signatur in den MBR geschrieben, damit Windows (ab W2k) mit den Festplatten umgehen kann.

Gegenwärtig ist dein MBR mit Partitionstabelle modifiziert.
Daher nicht zugeordnet oder unallocated.

Weißt du ob deine Platte vorher eine GPT-Partition hatte oder war es ein normaler MBR?
Baue vielleicht mal deine Platte zurück, um Kompatibilitätsprobleme auszuschließen?

Hast du für deine Platte ein USB-HUB mit eigener Stromversorgung um den USB-Strom zu glätten oder stabiliseren?
Für Testdisk ist es zwar besser ohne HUB für eine Diagnose direkt anzuschließen, aber bei Instabilitäten und wenn die Festplatte korrekt erkannt wird, kann es helfen.

Um zu versuchen deine Festplatte so wenig wie möglich zu stressen, kannst du folgendes tun.
Baue sie wieder zurück.
Setze mir einen Screen nach Analyse.
Starte Quick Search.
Wenn dein Bootsektor noch in Ordnung ist, kann deine Partition schnell gefunden wereden.
Wenn deine Partition richtig während des scans angezeigt wird, bestätige einfach mit Stop.
Setze mir einen Screen

Teste es erstmal.

Viele Grüße

Fiona

ChrisW
Posts: 6
Joined: 08 Mar 2012, 05:28

Re: WD 2TB extern - Partition weg, nicht zugeordnet

#3 Postby ChrisW » 08 Mar 2012, 09:46

Wow.. das ging schnell!
Und Du machst mir wieder Mut, dass vielleicht doch nicht alles zu spät ist, man steigert sich da ganz schön rein :roll:

Fiona wrote:Weißt du ob deine Platte vorher eine GPT-Partition hatte oder war es ein normaler MBR?
Baue vielleicht mal deine Platte zurück, um Kompatibilitätsprobleme auszuschließen?


Bingo! Ich hatte bis vor ein paar Tagen keine Ahnung was das beides überhaupt ist. Erst als ich eine fabrikneue Samsung (Datenrettung für die WD usw) in einem baugleichen Gehäuse anschloss, kam zum ersten mal diese Frage auf. Ich nahm damals das "empfohlene" MBR ... Dann also leichtfertig auch beim Umbau. Jetzt sagt Google mehrheitlich die My Book 3.0 wäre ab Werk wohl GPT und viele Benutzer berichten von Problemen beim Umwandeln zu MBR. EDIT: Ich bin damals nur mit der Standard Schnellformatierung (NTFS) über die Platte und die Frage nach MBR kam gar nicht (weil vorkonfiguriert?)

Fiona wrote:Hast du für deine Platte ein USB-HUB mit eigener Stromversorgung um den USB-Strom zu glätten oder stabiliseren?
Für Testdisk ist es zwar besser ohne HUB für eine Diagnose direkt anzuschließen, aber bei Instabilitäten und wenn die Festplatte korrekt erkannt wird, kann es helfen.


Die Verbindung ist ohne HUB direkt "externe Festplatte an PC USB Port" bzw. war bei der Quick Search vorhin "externe Festplatte direkt an eSATA".

Ich werde also die Platte nachher ins Original Gehäuse zurückbauen. Ich denke das bekomme schon wieder hin. Bei einer eventuellen Abfrage "MBR oder GPT" wähle ich dann wieder GPT? Oder kommt diese Abfrage nicht und die Analyse mit TestDisk wird wieder durch Inkompatibilität behindert? Ansonsten werde ich deiner Anleitung noch einmal folgen und alles dokumentieren ... Ich werde heute abend oder dann morgen berichten.

Vielen vielen Dank bis hierher,
und schöne Grüße Chris.

User avatar
Fiona
Posts: 2839
Joined: 18 Feb 2012, 17:19
Location: Ludwigsburg/Stuttgart - Germany

Re: WD 2TB extern - Partition weg, nicht zugeordnet

#4 Postby Fiona » 08 Mar 2012, 16:31

Normal erkennt Testdisk den Partitionstabellentyp automatisch.
Nur im Fall wenn man es genau weiß, sollte es geändert werden.
Ich werde es nicht kapieren, warum Festplatten kleiner als 2,2 TB nicht mit Intel MBR partitioniert werden.
In der jetzigen Zeit bietet es normal die höchste Kompatibilität.
Nur für Platten ab 2,2 TB muß die GUIP-Partitionszabelle gewählt werden (Globally Unique Identifier).
In deinem Fall ist wird es problematisch es festzulegen, da deine Partitionstabelle oder MBR geändert ist.
Kann ja Diagnose gemacht und im Fall gewechselt werden.
Fange mit Intel an!

Esata ist gut


Brauche Infos nach Analyse, Quick und im Fall Deeper Search.
Auch ob Daten gelistet werden.
Bilder während des Scans helfen nur bedingt, da ich immer das Ergebnis (Result) nach dem Scan benötige.

Viele Grüße

Fiona

ChrisW
Posts: 6
Joined: 08 Mar 2012, 05:28

Re: WD 2TB extern - Partition weg, nicht zugeordnet

#5 Postby ChrisW » 09 Mar 2012, 01:41

Hallo,

der Stand der Dinge ist noch folgender:
ich habe die Festplatte nun wieder im Original-Gehäuse (welch eine Konstruktion :roll: )

Beim Anschließen über USB 2.0 erscheint sie mit Bezeichnung unter "Sicher Entfernen" und im Geräte Manager,
wie befürchtet allerdings in der Datenverwaltung als nicht zugeordnet und es kommt die "MBR oder GPT" Abfrage. Da ich hier jetzt absolut verunsichert bin, hab ich erstmal abgebrochen. Nicht dass ich die Arbeit von TestDisk gleich wieder hier schon im Ansatz sabotiere ...
-> Laut vieler Aussagen im Netz ist die My Book USB 3.0 als 3TB Variante ab Werk GPT.
-> Leider weiß ich nun nicht ob meine My Book USB 3.0 2TB Variante das auch war? Zur Not werde ich dazu erstmal den WD Support kontaktieren

Ich weiß nicht, ob es in diesem Zustand der Platte Sinn macht, aber ich habe TestDisk dennoch einmal arbeiten lassen, und das hier sind soweit die Ergebnisse -> Screens

TestDisk_WD-ohneMBR_nach_Intel.JPG
TestDisk_WD-ohneMBR_nach_Intel.JPG (47.74 KiB) Viewed 3263 times

TestDisk_WD-ohneMBR_nach_Analyse.JPG
TestDisk_WD-ohneMBR_nach_Analyse.JPG (35.4 KiB) Viewed 3263 times

TestDisk_WD-ohneMBR_nach_QuickSearch.JPG
Es wird eine NTFS Partition gefunden ... vielleicht mit meinen Daten oder doch nur die ab Werk?
TestDisk_WD-ohneMBR_nach_QuickSearch.JPG (47.97 KiB) Viewed 3263 times


Eine Frage zum Listen der Daten: Zeigt TestDisk nach Drücken von "p" diese dann eigentlich "in Echtzeit" oder erst gemeinsam am Ende der Datei-Suche?

Wie sollte ich nun weiter vorgehen?

Nocheinmal Vielen Dank bis hierher und viele Grüße,
Chris

User avatar
Fiona
Posts: 2839
Joined: 18 Feb 2012, 17:19
Location: Ludwigsburg/Stuttgart - Germany

Re: WD 2TB extern - Partition weg, nicht zugeordnet

#6 Postby Fiona » 09 Mar 2012, 08:13

Wennn eine Partition gefunden wurde, zeigt Testdisk diese normal sofort.
Wenn es viele Dateien sind, kann es sein, das Testdisk einige Minuten braucht um alles zu listen.
Teile mit, ob du deine Daten gesehen hast?

Dann könnte die Partition wiederhergestellt werden.

Im Fall wenn du deine Daten gesehen hast;
Ich gehe von diesem Screen aus;
download/file.php?id=103
Bestätige dann mit Enter.

Gehe auf [Write].
Bestätige dort mit Enter, y und Ok.
Im Fall wenn bei dir ein Bootsektor defekt sein sollte, kann dort noch ein Menü Boot erscheinen.
Bestätige dann aber nur im Fall mit Backup BS.

Beende Testdisk und starte den Computer neu.

Wenn chkdsk bei Systemstart kommen will, beende chkdsk erstmal.
Geht innerhalb von 10 Sekunden durch beliebigen Tastendruck.

Überprüfe das Ergebnis und teile es mit.

Viele Grüße

Fiona

ChrisW
Posts: 6
Joined: 08 Mar 2012, 05:28

Re: WD 2TB extern - Partition weg, nicht zugeordnet

#7 Postby ChrisW » 09 Mar 2012, 09:43

Hallo Fiona,

Nach deiner Rückmeldung habe ich nun den Vorgang aus meinem letzten Post noch einmal wiederholt -> die gleichen screens wie oben. Diesmal habe ich mich auch getraut den Scan nach Dateien mit "p" bis zum Ende durchzuziehen (Sorry, bin im Umgang mit diesem mächtigen Tool auch nach viel Lesen noch sehr zögerlich :oops: )

Die Suche dauerte knapp 30min., es liegen ja auch 1,5TB auf der Platte (Aufnahmen mit mehreren GB pro Datei oder noch viele unbearbeitete kleinere Parts).

Am Ende wurde eine Ordnerstruktur sichtbar, die mir sehr bekannt vorkommt. :P
Auch der Inhalt einiger getesteter Ordner sieht vollständig aus!
Dann wurde ich mutig und wollte eine Datei nach C: kopieren, war leider sehr langsam... aber mit dem Befehl "p" werden zumindest schon einmal (viele) Dateien gelistet!

Darf ich das schon mal Teilerfolg von TestDisk feiern?

User avatar
Fiona
Posts: 2839
Joined: 18 Feb 2012, 17:19
Location: Ludwigsburg/Stuttgart - Germany

Re: WD 2TB extern - Partition weg, nicht zugeordnet

#8 Postby Fiona » 09 Mar 2012, 10:15

Ja, ist immer gut wenn Daten angezeigt werden.
Das Testdisk für eine Datei oder solange benötigt, ist eher merkwürdig.
Habe dir oben die Anleitung geschrieben, wie du die Partition korrekt wiederherstellen kannst.
Du hast ja keine Partition in der Partitionstabelle.
Trage die mit Testdisk mal wie beschrieben ein und starte dein Computer neu.
Achte erstmal auf chkdsk.

Viele Grüße

Fiona

ChrisW
Posts: 6
Joined: 08 Mar 2012, 05:28

Re: WD 2TB extern - Partition weg, nicht zugeordnet

#9 Postby ChrisW » 11 Mar 2012, 10:58

OK, ich melde mich mit einem lachenden und einem weinenden Auge zurück ...
Erstmal die Erfolgsmeldung: Nachdem ich alles wie beschrieben durchgeführt habe, kann ich sagen, dass die frühere Partition tatsächlich wiederhergestellt wurde!
Soweit ich es überblicken kann, sind auch ALLE Daten wieder da! :D
Allein hierfür schon einmal ein herzliches DANKE an TestDisk für die geniale Arbeit und an Fiona für den überragenden Support!

Leider bin ich aber nun wieder beim Anfangsproblem angelangt (siehe "Vorgeschichte"). Nach dem erforderlichen Neustart (nach "Write" und "y") startete Windows ohne chkdsk und zeigte gleich ein USB Gerät. Es dauerte aber minutenlang bis Windows Zugriff darauf hatte (Explorer, Gerätemanager, Datenträgerverwaltung). Schließlich taucht die HDD hier aber als fehlerfreies Gerät mit fehlerfreier NTFS Partition und Laufwerksbuchstaben auf. Die Navigation durch die Ordner oder das Markieren selbst kleiner Dateien zieht sich ewig hin.

Irgendwas ist hier im Argen, aber ich weiß nicht ob das noch die "Baustelle" von TestDisk ist!?

- Ich werde auf jeden Fall noch einmal die COPY Funktion im aktuellen Zustand auf Schnelligkeit testen.
- Eine andere Überlegung wäre: Ist es den Versuch wert, noch einmal ins andere Gehäuse umzubauen ... diesmal ohne "MBR - GPT Schnellschuss" und gleich via eSATA, mit der Hoffnung dass die Partition so erhalten bleibt und die Dateien mit TestDisk COPY schneller herüber wandern?
- Auch über Linux Live CDs habe ich schon gelesen, also unversucht werde ich nichts lassen ...

Als Alternative bleibt das Kopieren von 1,5TB mit max. halber USB 1.1 Speed und Abbruchrisiko :?
Aber um für jetzt positiv zu bleiben: Hauptsache die Dateien sind noch/wieder da!!

Viele Grüße,
Chris.

User avatar
Fiona
Posts: 2839
Joined: 18 Feb 2012, 17:19
Location: Ludwigsburg/Stuttgart - Germany

Re: WD 2TB extern - Partition weg, nicht zugeordnet

#10 Postby Fiona » 11 Mar 2012, 11:46

USB1.1?
Sollte zumindest USB2 sein.

Es ist kein Problem von TestDisk mehr!
Partition wurde repariert.
Schalte dir mal eine USB-HUB mit eigener Stromversorgung dazwischen, um den Datenstrom (5V) zu glätten oder zu stabilisieren.
Hatte oft geholfen, wenn große USB-Platten nicht formatiert werden konnten oder Probleme mit der Geschwindigkeit hatten.
Ein Y-USB-Kabel ist nicht immer hilfreich und bringt nur bis 100 mA.
Infos;
http://www.heise.de/ct/hotline/Was-nuet ... 22240.html

Kann auch Ursache für dein Problem sein.
Sicherlich Backup!, chkdsk und defrag sind als normale Wartung bei mechanische Festplatten wichtig.

Wenn dein Problem soweit erledigt ist, könntest du dein Problem auf solved setzen?
Ist neues Feature. Bin am überlegen hier auch eine Ankündigung zu schreiben.
Siehst du oben rechts mit den zwei Haken, Danke.
Dann brauchen wir da nichts machen und ist mir immer lieber! :)
Chkdsk sollte nicht ohne Backup ausgeführt werden.

Viele Grüße

Fiona


Return to “Partitionen wiederherstellen”

Who is online

Users browsing this forum: No registered users and 0 guests